diff mbox series

[bug#73048] gnu: gtk: Disable failing tests on aarch64.

Message ID a32fa91dd461f788945be7dcbff5ef8f5bb2782e.1725555398.git.roman@burningswell.com
State New
Headers show
Series [bug#73048] gnu: gtk: Disable failing tests on aarch64. | expand

Commit Message

Roman Scherer Sept. 5, 2024, 5:01 p.m. UTC
* gnu/packages/gtk.scm (gtk): Disable failing tests on aarch64.

Change-Id: Ia950b25fa2141daff0a01a69d9dfb551e26116ea
---
 gnu/packages/gtk.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 7d2ced8d6d9c38327592d312376d59a8c37fc160

Comments

Roman Scherer Sept. 5, 2024, 5:14 p.m. UTC | #1
The package has 180 dependent packages.
Liliana Marie Prikler Sept. 5, 2024, 8:15 p.m. UTC | #2
Am Donnerstag, dem 05.09.2024 um 19:01 +0200 schrieb Roman Scherer:
> * gnu/packages/gtk.scm (gtk): Disable failing tests on aarch64.
> 
> Change-Id: Ia950b25fa2141daff0a01a69d9dfb551e26116ea
> ---
Pushed as 54ec97bfda1969f9317596075338d4d92c6c3c12.

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b7650748af..3d4766713d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1242,6 +1242,34 @@  (define-public gtk
                 ;; related warnings (see:
                 ;; https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
                 (("[ \t]*'inscription-markup.ui',") ""))
+              ;; These tests fail on an Apple M1 (aarch64) with the following errors:
+              ;; - MESA: error: ZINK: failed to choose pdev
+              ;; - libEGL warning: egl: failed to create dri2 screen
+              ;; - MESA: error: ZINK: failed to choose pdev
+              ;; - glx: failed to create drisw screen
+              #$@(if (target-aarch64?)
+                     #~((substitute* "testsuite/gsk/meson.build"
+                          (("'border-bottom-right',") "")
+                          (("'border-one-rounded',") "")
+                          (("'border-opacity',") "")
+                          (("'border-zero-width-color',") "")
+                          (("'borders-rotated',") "")
+                          (("'borders-scaled',") "")
+                          (("'clip-in-smaller-rounded-clip',") "")
+                          (("'css-background',") "")
+                          (("'empty-border',") "")
+                          (("'empty-inset-shadow',") "")
+                          (("'empty-outset-shadow',") "")
+                          (("'inset-shadow-multiple',") "")
+                          (("'outset-shadow-scale-offset',") "")
+                          (("'outset_shadow_offset_both',") "")
+                          (("'outset_shadow_offset_x',") "")
+                          (("'outset_shadow_offset_y',") "")
+                          (("'outset_shadow_rounded_top',") "")
+                          (("'outset_shadow_simple',") "")
+                          (("'shadow-offset-clip',") "")
+                          (("'shrink-rounded-border',") "")))
+                     #~())
               ;; XXX: These failures appear specific to i686 – investigate them.
               #$@(if (target-x86-32?)
                      #~((substitute* "testsuite/gsk/meson.build"