diff mbox series

[bug#70971,1/3] gnu: dhewm3: Use git repository.

Message ID a32e0b02753e9797c877d9b129756b964898376f.1715820031.git.jsubuntuxp@disroot.org
State New
Headers show
Series Update dhewm3 | expand

Commit Message

James Smith May 16, 2024, 12:46 a.m. UTC
* gnu/packages/game-development.scm (dhewm3) [source]: Use git repository
instead of downloading a tarball from GitHub.

Change-Id: I81ff5de0687221d7eec64b0165dbf10c2d041260
---
 gnu/packages/game-development.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index bf0f984ec7..86d3cc0a06 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 dan <i@dan.games>
 ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3099,13 +3100,13 @@  (define-public dhewm3
     (name "dhewm3")
     (version "1.5.2")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/dhewm/dhewm3/releases/download/"
-                    version "/dhewm3-" version "-src.tar.xz"))
+              (method git-fetch)
+              (uri (git-reference (url "https://github.com/dhewm/dhewm3")
+                                  (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "10p0w1x5wx9b7d8mzvb6yqjia9prhkjwz04vbvphy8p383r33am6"))))
+                "056prmry1lag1pandcw058y5yzbah80ccmz8qlmlx9siz8zlxqyw"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; No tests.