diff mbox series

[bug#38905] gnu: Add gnome-initial-setup.

Message ID a31b185c581b45da91a8c6cc0943bcb039cf63e1.camel@disroot.org
State Accepted
Headers show
Series [bug#38905] gnu: Add gnome-initial-setup. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 3, 2020, 8:51 p.m. UTC
Hello Guix!

Please find the attached patch to add gnome-initial-setup.

Regards,
RG.

Comments

Julien Lepiller Jan. 7, 2020, 11:31 p.m. UTC | #1
Le Fri, 03 Jan 2020 15:51:58 -0500,
Raghav Gururajan <raghavgururajan@disroot.org> a écrit :

> Hello Guix!
> 
> Please find the attached patch to add gnome-initial-setup.
> 
> Regards,
> RG.

Thanks for the patch!

I have a few questions about it, even though I didn't try to build it
yet. What is optional in configure-flags? You should probably remove
the comment in the inputs (the package doesn't exist, right?).

I'm a bit puzzled by how this package works. Should some of these
inputs be propagated or hard-coded in the code of the package?
Shouldn't they be available at runtime? What does ibus, upower and the
like do for the build itself?

I think pkg-config should be a native-input.

The description is a bit vague. What does it do exactly? Maybe there's
some things that guix cannot setup and that's what it's used for? I'm
not sure what the policy for "aims to" is, but I think I would remove
it.
diff mbox series

Patch

From e295834ca7610994c56774a41c48c58f46053627 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 15:49:08 -0500
Subject: [PATCH] gnu: Add gnome-initial-setup.

* gnu/packages/gnome.scm (gnome-initial-setup): New variable.
---
 gnu/packages/gnome.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 102f679b53..54e643a7ab 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,55 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public gnome-initial-setup
+  (package
+   (name "gnome-initial-setup")
+   (version "3.32.1")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/gnome-initial-setup/"
+                                (version-major+minor version)
+                                "/gnome-initial-setup-" version ".tar.xz"))
+            (sha256
+             (base32
+              "1gwhp7dalyc8zsb2pa66cmpdrj2d6drbq5p331sq6zp8ds10k9ry"))))
+   (build-system meson-build-system)
+   (arguments
+    '(#:configure-flags '("-Dcheese=disabled" "-Dsystemd=false"))) ;;Optional
+   (inputs
+    `(("accountsservice" ,accountsservice)
+      ("adwaita-icon-theme" ,adwaita-icon-theme)
+      ("cheese" ,cheese)
+      ("gdm" ,gdm)
+      ("geoclue" ,geoclue)
+      ("gettext" ,gettext-minimal)
+      ("glib:bin" ,glib "bin")
+      ("gnome-desktop" ,gnome-desktop)
+      ("gnome-getting-started-docs" ,gnome-getting-started-docs)
+      ("gnome-online-accounts" ,gnome-online-accounts)
+      ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+      ("gstreamer" ,gstreamer)
+      ("gtk+:bin" ,gtk+ "bin")
+      ("ibus" ,ibus)
+      ("krb5" ,mit-krb5)
+      ("libgweather" ,libgweather)
+      ;;("libnma" ,libnma)
+      ("libsecret" ,libsecret)
+      ("network-manager" ,network-manager)
+      ("network-manager-applet" ,network-manager-applet) ;;libnma
+      ("packagekit" ,packagekit)
+      ("pkg-config" ,pkg-config)
+      ("polkit" ,polkit)
+      ("pwquality" ,libpwquality)
+      ("rest" ,rest)
+      ("upower" ,upower)
+      ("webkitgtk" ,webkitgtk)))
+   (synopsis "Initial setup wizard for GNOME desktop")
+   (description "GNOME Initial Setup aims to provide a simple, easy,
+and safe way to prepare a new system.")
+   (home-page "https://gitlab.gnome.org/GNOME/gnome-initial-setup")
+   (license license:gpl2)))
+
 (define-public gnome-color-manager
   (package
    (name "gnome-color-manager")
-- 
2.24.1