diff mbox series

[bug#56729,RFC,v3,02/32] gnu: cliquer: Update to 1.22.

Message ID a3122d24f5ed365e29ba60534cd35d4c7db85b08.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/sagemath.scm (cliquer): Update to 1.22.
---
 gnu/packages/sagemath.scm | 23 +++++++++++++----------
 1 file changed, 13 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 3d8c07b813..3138006e77 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -97,19 +97,22 @@  (define-public python-gmpy2
 (define-public cliquer
   (package
     (name "cliquer")
-    (version "1.21")
+    (version "1.22")
     ;; The original source package is available from the home page and
     ;; has not seen any release since 2010; it comes with only a Makefile
-    ;; without an "install" target. Instead, there is an autotoolized
-    ;; tarball available from the Sage project.
-    (source
-     (origin
-       (method url-fetch)
-       (uri "http://users.ox.ac.uk/~coml0531/sage/cliquer-1.21.tar.gz")
-       (sha256
-        (base32
-         "1hdzrmrx0nvvj8kbwxrs8swqgkd284khzl623jizixcv28xb77aq"))))
+    ;; without an "install" target. Instead, we use an autotoolized
+    ;; fork
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dimpase/autocliquer")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "00gcmrhi2fjn8b246w5a3b0pl7p6haxy5wjvd9kcqib1xanz59z4"))))
     (build-system gnu-build-system)
+    (native-inputs (list autoconf automake libtool))
     (synopsis "C routines for finding cliques in weighted graphs")
     (description "Cliquer is a set of reentrant C routines for finding
 cliques in a weighted or unweighted graph.  It uses an exact