diff mbox series

[bug#66644,master,1/3] gnu: tilda: Add version 1.6-alpha with D-Bus support

Message ID a309f174b07e259eaf2f4af5cdc747f0a9123a5b.1697747918.git.suhail@bayesians.ca
State New
Headers show
Series Add Tilda with D-Bus support (necessary for Wayland) | expand

Commit Message

Suhail Oct. 20, 2023, 7:51 p.m. UTC
* gnu/packages/terminals.scm (tilda-dbus): New variable.
---
 gnu/packages/terminals.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 989fd00e61..0c06a42213 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -187,6 +187,29 @@  (define-public tilda
     (home-page "https://github.com/lanoxx/tilda")
     (license license:gpl2+)))
 
+(define-public tilda-dbus
+  (package
+    (inherit tilda)
+    (name "tilda")
+    (version "1.6-alpha")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/lanoxx/tilda")
+             (commit "51a980a55ad6d750daa21d43a66d44577dad277b")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1pdarmlxkap9v689s88b89l5hi4vspsrrysh7pbm9rhdjmzk5m2c"))))
+    (synopsis "GTK+-based drop-down terminal with experimental D-Bus support")
+    (description
+     "Tilda is a terminal emulator similar to normal terminals like
+gnome-terminal (GNOME) or Konsole (KDE), with the difference that it drops down
+from the edge of a screen when a certain configurable hotkey is pressed.  This
+is similar to the built-in consoles in some applications.  Tilda is highly
+configurable through a graphical wizard.  This version enables D-Bus support
+which is necessary for using Tilda on Wayland.")))
+
 (define-public termite
   (package
     (name "termite")