diff mbox series

[bug#66784,1/4] gnu: dunst: Update to 1.9.2.

Message ID a2aebf6851976bae4f3f533f7113f641282bb4a1.1699127223.git.jaeme@runbox.com
State New
Headers show
Series Update dunst | expand

Commit Message

Jaeme Sifat Nov. 4, 2023, 7:55 p.m. UTC
* gnu/packages/dunst.scm (dunst): Update to 1.9.2.

Change-Id: Ic13f1679074462918991a1ceba8571a46e721224
---
 gnu/packages/dunst.scm | 76 ++++++++++++++++++++++--------------------
 1 file changed, 39 insertions(+), 37 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/dunst.scm b/gnu/packages/dunst.scm
index 4a8ff59ec9..ee389098fb 100644
--- a/gnu/packages/dunst.scm
+++ b/gnu/packages/dunst.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,6 +25,7 @@ 
 
 (define-module (gnu packages dunst)
   #:use-module (guix packages)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix utils)
@@ -41,45 +43,45 @@  (define-module (gnu packages dunst)
 (define-public dunst
   (package
     (name "dunst")
-    (version "1.9.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/dunst-project/dunst")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1nfxf2rahngxpy606yrizrz16d0pswl5sa9jfzpv7h19x6xy24vx"))))
+    (version "1.9.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dunst-project/dunst")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17zrw7jrnlyln81pxw7p4jgvl7j1w1gf488nfskhns6j6dcz90gh"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; no check target
-       #:make-flags (list (string-append "CC=" ,(cc-for-target))
-                          (string-append "PREFIX=" %output)
-                          (string-append "SYSCONFDIR=" %output "/etc")
-                          ;; Otherwise it tries to install service file
-                          ;; to "dbus" store directory.
-                          (string-append "SERVICEDIR_DBUS=" %output
-                                         "/share/dbus-1/services")
-                          "dunstify")
-       #:phases (modify-phases %standard-phases
-                  (delete 'configure))))
-    (native-inputs
-     (list pkg-config perl ; for pod2man
-           which))
-    (inputs
-     (list dbus
-           (librsvg-for-system) ; for svg support
-           glib
-           cairo
-           pango
-           libnotify ; for dunstify
-           libx11
-           libxscrnsaver
-           libxinerama
-           libxrandr
-           libxdg-basedir
-           wayland))           ; for wayland support
+     (list
+      #:tests? #f ;no check target
+      #:make-flags #~(list (string-append "CC="
+                                          #$(cc-for-target))
+                           (string-append "PREFIX=" %output)
+                           (string-append "SYSCONFDIR=" %output "/etc")
+                           ;; Otherwise it tries to install service file
+                           ;; to "dbus" store directory.
+                           (string-append "SERVICEDIR_DBUS=" %output
+                                          "/share/dbus-1/services")
+                           "dunstify")
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'configure))))
+    (native-inputs (list pkg-config perl ;for pod2man
+                         which))
+    (inputs (list dbus
+                  (librsvg-for-system) ;for svg support
+                  glib
+                  cairo
+                  pango
+                  libnotify ;for dunstify
+                  libx11
+                  libxscrnsaver
+                  libxinerama
+                  libxrandr
+                  libxdg-basedir
+                  wayland)) ;for wayland support
     (home-page "https://dunst-project.org/")
     (synopsis "Customizable and lightweight notification daemon")
     (description