diff mbox series

[bug#64361,v2] gnu: python-wand: Honor #:tests? argument.

Message ID a26b81e92e1415911c209c5e5ffc779bcff4e959.1689597664.git.hako@ultrarare.space
State New
Headers show
Series [bug#64361,v2] gnu: python-wand: Honor #:tests? argument. | expand

Commit Message

Hilton Chain July 17, 2023, 12:43 p.m. UTC
Fixes <https://issues.guix.gnu.org/64350>.

* gnu/packages/python-xyz.scm (python-wand)[arguments]<#:phases>: Pass keyword
argument #:tests? to 'check.

Reported-by: Thorsten Wilms <t_w_@freenet.de>
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: ad08f9331fee7a8e71e94b02f86f54ab3e1001a8

Comments

Bruno Victal July 19, 2023, 4:45 a.m. UTC | #1
Fixed with 13cb9b302868b5a966a6ae177412c474084f4bf1.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 973216c5ed..f07ae0b1f9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2446,7 +2446,7 @@  (define-public python-wand
              (setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
              (setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16")))
          (replace 'check
-           (lambda _
+           (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
                (invoke "pytest" "-vv")))))))
     (native-inputs