diff mbox series

[bug#39312] gnu: Add chatty.[v2]

Message ID a2485300-0a7b-0f10-2c6e-5118421871cb@web.de
State Accepted
Headers show
Series [bug#39312] gnu: Add chatty.[v2] | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jonathan Brielmaier Jan. 31, 2020, 4:04 p.m. UTC
This time patch v2 without purple-mm-sms, as it's not included yet.

On 27.01.20 19:25, Jonathan Brielmaier wrote:
> Hi,
>
> attached is a patch for Chatty. A GUI program for SMS and XMPP optimized
> for mobile interfaces. XMPP works nicely already. SMS not yet: I have
> the required package "purple-mm-sms" already in my local git, but
> couldn't test it yet, because I lack the hardware. I'll submit it
> separately as soon it's ready and tested :)
>
> ~Jonathan

Comments

Leo Famulari Feb. 2, 2020, 7:37 p.m. UTC | #1
On Fri, Jan 31, 2020 at 05:04:52PM +0100, Jonathan Brielmaier wrote:
> This time patch v2 without purple-mm-sms, as it's not included yet.

Okay!

> From 87e4b48eae543d53c7d80bf031dd93671186e45f Mon Sep 17 00:00:00 2001
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
> Date: Thu, 23 Jan 2020 21:32:39 +0100
> Subject: [PATCH] gnu: Add chatty.
> 
> * gnu/packages/messaging.scm (chatty): New variable.
> ---
>  gnu/packages/messaging.scm | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)
> 
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index 5754c7ce08..1dba50d55c 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -2041,4 +2041,39 @@ support for high performance Telegram Bot creation.")
>      (home-page "https://source.puri.sm/Librem5/purple-mm-sms")
>      (license license:gpl2+)))
> 
> +(define-public chatty

Except that it's still part of the context of this patch (the first two
lines) and so the patch doesn't apply. Can you send a v3?
diff mbox series

Patch

From 87e4b48eae543d53c7d80bf031dd93671186e45f Mon Sep 17 00:00:00 2001
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Date: Thu, 23 Jan 2020 21:32:39 +0100
Subject: [PATCH] gnu: Add chatty.

* gnu/packages/messaging.scm (chatty): New variable.
---
 gnu/packages/messaging.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5754c7ce08..1dba50d55c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2041,4 +2041,39 @@  support for high performance Telegram Bot creation.")
     (home-page "https://source.puri.sm/Librem5/purple-mm-sms")
     (license license:gpl2+)))

+(define-public chatty
+ (package
+   (name "chatty")
+   (version "0.1.7")
+   (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://source.puri.sm/Librem5/chatty.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1prqd2dnib3j12pjiplzr2rim9q617vmvzv76lgmz0n3bmp7v7ma"))))
+   (build-system meson-build-system)
+   (native-inputs
+     `(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+       ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+       ("folks" ,folks)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("libgcrypt" ,libgcrypt)
+       ("libgee" ,libgee)
+       ("libhandy" ,libhandy)
+       ("pidgin" ,pidgin)
+       ("pkg-config" ,pkg-config)
+       ("sqlite" ,sqlite)))
+   (propagated-inputs
+     `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+   (synopsis "Mobile client for XMPP and SMS messaging")
+   (description "Chatty is a chat program for XMPP and SMS.  It works on mobile
+as well as on desktop platforms.  It's based on libpurple and ModemManager.")
+   (home-page "https://source.puri.sm/Librem5/chatty")
+   (license license:gpl3+)))
+
 ;;; messaging.scm ends here
--
2.24.1