[bug#74723,12/19] gnu: Add libbinio.

Message ID a2398bd763e88f28416ddeb23240dba40bf2c471.1733563475.git.sughosha@disroot.org
State New
Headers
Series gnu: lmms, carla: New features, fixes and updates. |

Commit Message

Sughosha Dec. 7, 2024, 12:20 p.m. UTC
  * gnu/packages/cpp.scm (libbinio): New variable.

Change-Id: I3f202f6da8617162654a8b4523b680a497909ba3
---
 gnu/packages/cpp.scm | 37 ++++++++++++++++++++++++++++++++++++-
 1 file changed, 36 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index eacc6e46ab..7266efeb2a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -33,7 +33,7 @@ 
 ;;; Copyright © 2022-2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
-;;; Copyright © 2023 Sughosha <Sughosha@proton.me>
+;;; Copyright © 2023, 2024 Sughosha <Sughosha@proton.me>
 ;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2023 Liliana Marie Prikler <liliana.prikler@gmail.com>
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -111,6 +111,7 @@  (define-module (gnu packages cpp)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages pulseaudio)
+  #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml)
@@ -1834,6 +1835,40 @@  (define-public aws-sdk-cpp
     (home-page "https://github.com/aws/aws-sdk-cpp")
     (license license:asl2.0)))
 
+(define-public libbinio
+  (package
+    (name "libbinio")
+    (version "1.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/adplug/libbinio")
+                    (commit (string-append "libbinio-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "010q3dgn8zdv5hnvbhhr0jzgzvhrmil395hx585yy7gsi8dsyr35"))
+              (modules '((guix build utils)))
+              (snippet
+               `(substitute* "doc/libbinio.texi"
+                  ;; Do not include version.texi which does not exist yet.
+                  ((".*version\\.texi.*") "")
+                  ;; Replace VERSION with the package version.
+                  (("@value\\{VERSION\\}") ,version)
+                  ;; Replace UPDATED with the date of the current commit.
+                  (("@value\\{UPDATED\\}") "7 August 2019")))))
+    (native-inputs
+     (list autoconf automake libtool texinfo))
+    (build-system gnu-build-system)
+    (home-page "http://adplug.github.io/libbinio/")
+    (synopsis "Binary I/O stream class library")
+    (description
+     "This binary I/O stream class library presents a platform-independent way
+to access binary data streams in C++.  The library is hardware independent in
+the form that it transparently converts between the different forms of
+machine-internal binary data representation.")
+    (license license:lgpl2.1+)))
+
 (define-public libexpected
   (package
     (name "libexpected")