diff mbox series

[bug#53019,v4,2/2] gnu: Add aerich.

Message ID a22088e4cb0e6d192cc996153d9b2bcaff8564c4.1698581244.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,v4,1/2] gnu: Add python-ddlparse. | expand

Commit Message

Giacomo Leidi Oct. 29, 2023, 12:07 p.m. UTC
* gnu/packages/databases.scm (aerich): New variable.

Change-Id: I322d619dc80c943d50e28a96ba74d276784ab8da
---
 gnu/packages/databases.scm | 44 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

Comments

Christopher Baines Oct. 30, 2023, 11:26 a.m. UTC | #1
Giacomo Leidi via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/databases.scm (aerich): New variable.
>
> Change-Id: I322d619dc80c943d50e28a96ba74d276784ab8da
> ---
>  gnu/packages/databases.scm | 44 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 44 insertions(+)

This and the previous patch look good to me, I've tweaked a synopsis and
description to use @acronym and pushed this to master as
db5c83e83bb0aa7b65e020ee1d8749e11d5c8f6f.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 4bc642aa17..3abfa2773f 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -61,6 +61,7 @@ 
 ;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2023 Felix Gruber <felgru@posteo.ne
 ;;; Copyright © 2023 Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2023 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3113,6 +3114,49 @@  (define-public python-tortoise-orm
 with relational data.")
     (license license:asl2.0)))
 
+(define-public aerich
+  (package
+    (name "aerich")
+    (version "0.7.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tortoise/aerich")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0pcy945bg890p12s7cyw0mg7hxwsxyy570j600sbf7kwj2d3lilg"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list
+      poetry
+      python-bandit
+      python-cryptography
+      python-isort
+      python-pydantic
+      python-pytest
+      python-pytest-asyncio
+      python-pytest-mock
+      python-pytest-xdist))
+    (propagated-inputs
+     (list python-asyncmy
+           python-asyncpg
+           python-click
+           python-ddlparse
+           python-dictdiffer
+           python-tomlkit
+           python-tortoise-orm))
+    (home-page "https://github.com/tortoise/aerich")
+    (synopsis "Database migrations tool for Tortoise ORM (Object Relational
+Mapper)")
+    (description
+     "This package provides @code{aerich}, a Python database migrations tool
+for Tortoise ORM (Object Relational Mapper).  It can be used both
+programmatically or as a standalone CLI application.")
+    (license license:asl2.0)))
+
 (define-public sqlcipher
   (package
     (name "sqlcipher")