[bug#76746,v2,08/13] gnu: Add python-syncedlyrics.
Commit Message
* gnu/packages/python-web.scm (python-syncedlyrics): New variable.
Change-Id: I07915603eb234ca7952c3a682510f96e4d634f10
---
gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
@@ -10695,6 +10695,31 @@ (define-public python-shopifyapi
list, create, update, or delete resources (e.g. Order, Product, Collection).")
(license license:expat)))
+(define-public python-syncedlyrics
+ (package
+ (name "python-syncedlyrics")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "syncedlyrics" version))
+ (sha256
+ (base32 "1c361xwxzcxq1vz2wilva8hr2x5s8kgidsxldgcxavasxmlj9crx"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-poetry-core python-setuptools python-wheel))
+ (propagated-inputs (list python-beautifulsoup4
+ python-requests
+ python-rapidfuzz))
+ (arguments
+ (list
+ #:tests? #f)) ;Tests require network
+ (home-page "https://github.com/moehmeni/syncedlyrics")
+ (synopsis "Library to fetch lyrics from common online lyrics providers")
+ (description
+ "A Python 3 library to get LRC format synchronized lyrics for your
+music.")
+ (license license:expat)))
+
(define-public python-whatthepatch
(package
(name "python-whatthepatch")