diff mbox series

[bug#72078] gnu: Add emacs-palimpsest

Message ID a1751cecf3c6c624d79781589575b484484d055e.1720796152.git.daniel.szmulewicz@gmail.com
State New
Headers show
Series [bug#72078] gnu: Add emacs-palimpsest | expand

Commit Message

Daniel Szmulewicz July 12, 2024, 2:57 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-palimpsest): New variable.

Change-Id: I6e87534db55dd6a03fbcfbc1b13c306c91926343
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: 2d6a3799fcda5c017f653c6e96b91964b07a7ee0

Comments

Nicolas Goaziou July 21, 2024, 12:11 p.m. UTC | #1
Hello,

Daniel Szmulewicz <daniel.szmulewicz@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-palimpsest): New variable.

Applied, with a few changes.

> +             (url "https://github.com/danielsz/Palimpsest.git")

I removed the ".git" suffix.

> +             (commit "f474b3ad706373d9953abdc401d683a2a023d28e")))

I bound the commit hash to a `commit' variable.

> +    (synopsis "A minor mode for Emacs that provides several strategies to remove text without permanently deleting it.")

I reworded the synopsis so it doesn't start with an article and end with
a full stop.

> +    (description
> +     "Send selected text to the bottom of the buffer, or the top, or
> to a designated file. Useful in text mode when writing prose,
> articles, blog posts, academic papers, etc.")

I reworded the description so it consists of full sentences only.

Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 99e1d4c65c..0f5318a949 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1963,6 +1963,26 @@  (define-public emacs-pacfiles-mode
 files left by ArchLinux's pacman.")
     (license license:expat)))
 
+(define-public emacs-palimpsest
+  (package
+    (name "emacs-palimpsest")
+    (version "1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/danielsz/Palimpsest.git")
+             (commit "f474b3ad706373d9953abdc401d683a2a023d28e")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0wzxl1zcbm3svspjpjzvx92is1k9sz7g0a99r8q066j2364la0zh"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/danielsz/Palimpsest")
+    (synopsis "A minor mode for Emacs that provides several strategies to remove text without permanently deleting it.")
+    (description
+     "Send selected text to the bottom of the buffer, or the top, or to a designated file. Useful in text mode when writing prose, articles, blog posts, academic papers, etc.")
+    (license license:gpl3+)))
+
 (define-public emacs-minions
   (package
     (name "emacs-minions")