[bug#76719,v2,1/2] gnu: Add mt32emu.

Message ID a1722c628f15c05b9d2af34cc390275bacdfa32b.1741114063.git.wongandj@icloud.com
State New
Headers
Series [bug#76719,v2,1/2] gnu: Add mt32emu. |

Commit Message

Andrew Wong March 4, 2025, 6:47 p.m. UTC
  * gnu/packages/audio.scm (mt32emu): New variable.

Change-Id: I458e4722ac012935814643a2925e185c46ecaba3
---
 gnu/packages/audio.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 5f4c785fc3caa0fd960ebcf9c1ea6ab396b96f25
  

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 9f50f7f940..d592f33c5e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -53,6 +53,7 @@ 
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2025 Junker <dk@junkeria.club>
 ;;; Copyright © 2025 Sughosha <sughosha@disroot.org>
+;;; Copyright © 2025 Andrew Wong <wongandj@icloud.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2030,6 +2031,34 @@  (define-public midicomp
       (home-page "https://github.com/markc/midicomp")
       (license license:agpl3))))
 
+(define-public mt32emu
+  (package
+    (name "mt32emu")
+    (version "2.7.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/munt/munt")
+             (commit
+              (string-append "libmt32emu_"
+                             (string-replace-substring version "." "_")))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "06d3jzx69nwy9jj6jv9q6rhq5399mp51w6d5mijg3fmwr4al13fd"))))
+    (build-system cmake-build-system)
+    (arguments (list
+                #:tests? #f             ;no tests.
+                #:configure-flags #~(list "-Dmunt_WITH_MT32EMU_SMF2WAV=FALSE"
+                                          "-Dmunt_WITH_MT32EMU_QT=FALSE")))
+    (home-page "https://sourceforge.net/projects/munt/")
+    (synopsis "Pre-GM Roland MIDI device emulator")
+    (description
+     "libmt32emu is a C/C++ library which approximately emulates
+the Roland MT-32, CM-32L and LAPC-I synthesizer modules. It is part of the
+Munt project.")
+    (license license:gpl2+)))
+
 (define-public clalsadrv
   (package
     (name "clalsadrv")