diff mbox series

[bug#74233,PATCHv2,rust-team,01/40] gnu: Add rust-search-provider-0.8.

Message ID a161eaf11e17153794249a814b41a809efd5a3d5.1731018145.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#74233,PATCHv2,rust-team,01/40] gnu: Add rust-search-provider-0.8. | expand

Commit Message

Giacomo Leidi Nov. 7, 2024, 10:21 p.m. UTC
* gnu/packages/crates-gtk.scm (rust-search-provider-0.8): New variable.

Change-Id: I3caa5a13ef6513d2a536b07dc14e6247e18ecf9b
---
 gnu/packages/crates-gtk.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: baf5c3f0614bd7fd6e60d216e2c202a7761ef522
diff mbox series

Patch

diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 17afb65321..b88632de88 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -4105,6 +4105,31 @@  (define-public rust-pangocairo-sys-0.15
        (("rust-shell-words" ,rust-shell-words-1)
         ("rust-tempfile" ,rust-tempfile-3))))))
 
+(define-public rust-search-provider-0.8
+  (package
+    (name "rust-search-provider")
+    (version "0.8.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "search-provider" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1a683ndxh99sin4lr919wc8aakzgjiqlic1xglf4qs6gfpvs2prq"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-futures-channel" ,rust-futures-channel-0.3)
+                       ("rust-futures-util" ,rust-futures-util-0.3)
+                       ("rust-gdk-pixbuf" ,rust-gdk-pixbuf-0.20)
+                       ("rust-gdk4" ,rust-gdk4-0.8)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-zbus" ,rust-zbus-4))))
+    (home-page "https://gitlab.gnome.org/World/Rust/search-provider")
+    (synopsis "Rust wrapper around the GNOME Shell search provider API")
+    (description
+     "This package provides Rust wrapper around the GNOME Shell search provider API.")
+    (license license:gpl3+)))
+
 (define-public rust-soup-sys-0.10
   (package
     (name "rust-soup-sys")