diff mbox series

[bug#38097] Add gnome-xyz for themes and shell extensions

Message ID a135221fe444ba667529d555c7289ecea14bba1e.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#38097] Add gnome-xyz for themes and shell extensions | expand

Commit Message

Leo Prikler Nov. 7, 2019, 9:46 a.m. UTC
This patch series adds (gnu packages gnome-xyz) for GNOME themes[1] and
extensions[2].  I've initialized it with some packages that I
personally use.  Another potential candidate for inclusion into this
file would for instance be the Matcha GTK theme (bug#38095).

I'm not 100% sure on the licenses.  In some places, I only found
LICENSE files without a comment specifying "or later" elsewhere --
perhaps I've overlooked some.  For now, I'm using the stricter versions
(sans "+").

[1] https://www.gnome-look.org/
[2] https://extensions.gnome.org/

Comments

Mathieu Othacehe Nov. 7, 2019, 11:36 a.m. UTC | #1
Hello,

Overall this looks fine, thanks. The indentation of the first patch is
wrong. Also you have several lines hitting the 78 columns limit. You
need to wrap them manually.

I'm ok with the introduction of (gnu packages gnome-xyz) and using it
for Matcha theme.

Can you please send an updated version?

Thanks,

Mathieu

> This patch series adds (gnu packages gnome-xyz) for GNOME themes[1] and
> extensions[2].  I've initialized it with some packages that I
> personally use.  Another potential candidate for inclusion into this
> file would for instance be the Matcha GTK theme (bug#38095).
>
> I'm not 100% sure on the licenses.  In some places, I only found
> LICENSE files without a comment specifying "or later" elsewhere --
> perhaps I've overlooked some.  For now, I'm using the stricter versions
> (sans "+").
>
> [1] https://www.gnome-look.org/
> [2] https://extensions.gnome.org/
diff mbox series

Patch

From 90c2d6c4fae02717b607eff29f546d07ce45edea Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Thu, 7 Nov 2019 10:22:02 +0100
Subject: [PATCH 3/3] gnu: add gnome-shell-extension-noannoyance

* gnu/packages/gnome-xyz: (gnome-shell-extension-noannoyance): New variable.
---
 gnu/packages/gnome-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 86e3b5989b..d09b0428bb 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -94,3 +94,34 @@  transforming it into a dock for easier application launching and faster window
 switching.")
     (home-page "https://micheleg.github.io/dash-to-dock/")
     (license license:gpl2+)))
+
+(define-public gnome-shell-extension-noannoyance
+  (package
+    (name "gnome-shell-extension-noannoyance")
+    (version "5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/BjoernDaase/noannoyance.git")
+                    (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
+              (sha256
+               (base32
+                "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
+              (file-name (git-file-name name version))))
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let ((dst (string-append
+                     (assoc-ref %outputs "out")
+                     "/share/gnome-shell/extensions/"
+                     "noannoyance@daase.net")))
+           (mkdir-p dst)
+           (copy-recursively (assoc-ref %build-inputs "source") dst)))))
+    (synopsis "Removes 'Window is ready' annotation")
+    (description "One of the many extensions, that remove this annoying message.
+It uses ES6 syntax and claims to be more actively maintained than others.")
+    (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
+    (license license:gpl2)))
-- 
2.24.0