diff mbox series

[bug#66731] gnu: wine and wine64: Update to 8.18.

Message ID a1221b0943f2646b39b47d904fb3447eb433135e.1698168982.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#66731] gnu: wine and wine64: Update to 8.18. | expand

Commit Message

Kaelyn Takata Oct. 24, 2023, 5:36 p.m. UTC
* gnu/packages/wine.scm (wine-minimal): Update to 8.18.
[properties]: Set upstream-name.

Change-Id: I018c320a990bf101d193095b68c44312ce9653a4
---
 gnu/packages/wine.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)


base-commit: f3714b3d5f51aced4b31447c42d5e89c75e3079f

Comments

Christopher Baines Nov. 3, 2023, 10:27 a.m. UTC | #1
Kaelyn Takata via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/wine.scm (wine-minimal): Update to 8.18.
> [properties]: Set upstream-name.
>
> Change-Id: I018c320a990bf101d193095b68c44312ce9653a4
> ---
>  gnu/packages/wine.scm | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Thanks for the patch! I tweaked the commit message to say wine-minimal
rather than wine and wine64, since that's where the change is being
made, and pushed this to master as
ada7e0d04286d800197cc06752ea1b4a0f8a91d0.

Chris
Kaelyn Takata Nov. 3, 2023, 4:19 p.m. UTC | #2
------- Original Message -------
On Friday, November 3rd, 2023 at 3:27 AM, Christopher Baines <mail@cbaines.net> wrote:


> 
> 
> 
> Kaelyn Takata via Guix-patches via guix-patches@gnu.org writes:
> 
> > * gnu/packages/wine.scm (wine-minimal): Update to 8.18.
> > [properties]: Set upstream-name.
> > 
> > Change-Id: I018c320a990bf101d193095b68c44312ce9653a4
> > ---
> > gnu/packages/wine.scm | 5 +++--
> > 1 file changed, 3 insertions(+), 2 deletions(-)
> 
> 
> Thanks for the patch! I tweaked the commit message to say wine-minimal
> rather than wine and wine64, since that's where the change is being
> made, and pushed this to master as
> ada7e0d04286d800197cc06752ea1b4a0f8a91d0.
> 
> Chris

Sounds good, thank you! I titled it as wine and wine64 as:
a) that was how commit a965ff448d updating the packages to 8.16 was titled, and
b) updating the version of wine-minimal also updates the version of wine and wine64 because of how the package definitions are structured, and wine and wine64 are the user-facing packages.

Cheers,
Kaelyn
diff mbox series

Patch

diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 3822165f7f..400f0e7607 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -79,7 +79,7 @@  (define-module (gnu packages wine)
 (define-public wine-minimal
   (package
     (name "wine-minimal")
-    (version "8.16")
+    (version "8.18")
     (source
      (origin
        (method url-fetch)
@@ -91,7 +91,8 @@  (define-public wine-minimal
               (string-append "https://dl.winehq.org/wine/source/" dir
                              "wine-" version ".tar.xz")))
        (sha256
-        (base32 "1zgkqflqgl2y3a90f2nvcc1vhzr9ni0lps276553j8zgbqvnd0hn"))))
+        (base32 "1nv06awb3hv26v64nqnks9yiz7w368scxznj77vxa3zpmhafzyih"))))
+    (properties '((upstream-name . "wine")))
     (build-system gnu-build-system)
     (native-inputs (list bison flex))
     (inputs `())