diff mbox series

[bug#67123,v2,1/1] gnu: Add pass-coffin

Message ID a108471701508856557e586c97ed1fdb08800db6.1708763265.git.steve@futurile.net
State New
Headers show
Series gnu: Add pass-coffin | expand

Commit Message

Steve George Feb. 24, 2024, 8:39 a.m. UTC
From: Christian Miller via Guix-patches via <guix-patches@gnu.org>

* gnu/packages/password-utils.scm (pass-coffin): New variable.

Reviewed-by: Steve George <steve@futurile.net>

Change-Id: I2fdf6c755b9b75780c5a3c0304e5b961a15640a4
---
 gnu/packages/password-utils.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index b79fdfc6a0f..09be72cfa6b 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -39,6 +39,7 @@ 
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2023 Christian Miller <christian.miller@dadoes.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1562,6 +1563,37 @@  (define-public pass-tomb
 pass-tomb to automatically close your store after a given time.")
     (license license:gpl3+)))
 
+(define-public pass-coffin
+  (package
+    (name "pass-coffin")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ayushnix/pass-coffin")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1486ikwsdjsj74qf949vk47r8mfp2mbbdc3scs8786nnnkhzc89n"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f ;No tests
+      #:make-flags #~(list (string-append "PREFIX="
+                                          #$output)
+                           (string-append "BASHCOMPDIR="
+                                          #$output "/etc/bash_completion.d"))
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'configure))))
+    (inputs (list password-store tar))
+    (home-page "https://github.com/ayushnix/pass-coffin")
+    (synopsis "Pass extension to keep the tree of passwords encrypted")
+    (description
+     "Pass-coffin is a pass extension that hides the password store
+data inside a GPG encrypted file, which we'll call a coffin.")
+    (license license:gpl3)))
+
 (define-public xkcdpass
   (package
     (name "xkcdpass")