diff mbox series

[bug#67618] gnu: harfbuzz: Update to 8.3.0.

Message ID a1045313f42408c1dd333d2d435d7788aead20aa.1701673912.git.mail@timmydouglas.com
State New
Headers show
Series [bug#67618] gnu: harfbuzz: Update to 8.3.0. | expand

Commit Message

Timmy Douglas Dec. 4, 2023, 7:11 a.m. UTC
* gnu/packages/gtk.scm (harfbuzz): Update to 8.3.0.
---

I was trying to install some software and found that it depended on a
newer version of harfbuzz.  I wasn't sure how to verify this doesn't
cause issues with other packages that have this as a dependency.
Thanks!

gnu/packages/gtk.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: 6e2dd51df5f3f51e9056dd4f2e1b036195ab3caa

Comments

Maxim Cournoyer Dec. 4, 2023, 3:21 p.m. UTC | #1
Hello,

Timmy Douglas <mail@timmydouglas.com> writes:

> I was trying to install some software and found that it depended on a
> newer version of harfbuzz.  I wasn't sure how to verify this doesn't
> cause issues with other packages that have this as a dependency.
> Thanks!

You can find dependents with 'guix refresh -l harfbuzz' and then attempt
to rebuild them with --keep-going (-k) to see how many of them fails.

I have a set of dirty scripts to help automate these tasks [0].

[0]  https://notabug.org/apteryx/guix-api-examples/src/master/command-line-hacks.sh
Liliana Marie Prikler Dec. 4, 2023, 7:19 p.m. UTC | #2
Am Montag, dem 04.12.2023 um 10:21 -0500 schrieb Maxim Cournoyer:
> Hello,
> 
> Timmy Douglas <mail@timmydouglas.com> writes:
> 
> > I was trying to install some software and found that it depended on
> > a newer version of harfbuzz.  I wasn't sure how to verify this
> > doesn't cause issues with other packages that have this as a
> > dependency.
> > Thanks!
> 
> You can find dependents with 'guix refresh -l harfbuzz' and then
> attempt to rebuild them with --keep-going (-k) to see how many of
> them fails.
> 
> I have a set of dirty scripts to help automate these tasks [0].
Adding to that, harfbuzz is a well known GNOME world rebuild (being a
dependency of Pango), so I'll try to build pango and hopefully gtk from
it, but we'll defer this to the gnome-team branch :)

Cheers
Timmy Douglas Dec. 6, 2023, 5:32 a.m. UTC | #3
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Montag, dem 04.12.2023 um 10:21 -0500 schrieb Maxim Cournoyer:
>> Hello,
>> 
>> Timmy Douglas <mail@timmydouglas.com> writes:
>> 
>> > I was trying to install some software and found that it depended on
>> > a newer version of harfbuzz.  I wasn't sure how to verify this
>> > doesn't cause issues with other packages that have this as a
>> > dependency.
>> > Thanks!
>> 
>> You can find dependents with 'guix refresh -l harfbuzz' and then
>> attempt to rebuild them with --keep-going (-k) to see how many of
>> them fails.
>> 
>> I have a set of dirty scripts to help automate these tasks [0].
> Adding to that, harfbuzz is a well known GNOME world rebuild (being a
> dependency of Pango), so I'll try to build pango and hopefully gtk from
> it, but we'll defer this to the gnome-team branch :)


Thanks for the script and info. If I ran the commands correctly, it seems
almost everything rebuilt (I had an issue using the weather command to
remove bad packages):

./pre-inst-env guix build --keep-going $packages_to_build
[snip]
...
successfully built /gnu/store/wb49g7l2mvzzcl0j7z3av97qrl5iyvlb-yubikey-oath-dmenu-0.13.0.drv
guix build: error: build of `/gnu/store/fccggj5fmcr2mbcia8mc2pba7rfbs4dj-zathura-pdf-mupdf-0.4.0.drv', `/gnu/store/s5wc25hwld9cl3hds3qa25y7i2566l59-youtube-viewer-3.8.1.drv' failed


Given this is going to the gnome-team and I don't know the timeline for
that, generally speaking, do people just run ./pre-inst-env guix upgrade
if they want something locally?

Thanks
Maxim Cournoyer Dec. 6, 2023, 5:48 p.m. UTC | #4
Hi,

Timmy Douglas <mail@timmydouglas.com> writes:

[...]

> Given this is going to the gnome-team and I don't know the timeline for
> that, generally speaking, do people just run ./pre-inst-env guix upgrade
> if they want something locally?

That's one way, yes.  Another way would be to maintain a channel, but
that's more work.
Liliana Marie Prikler Dec. 19, 2023, 10:57 p.m. UTC | #5
Am Dienstag, dem 05.12.2023 um 21:32 -0800 schrieb Timmy Douglas:
> [...]
> Given this is going to the gnome-team and I don't know the timeline
> for that, generally speaking, do people just run ./pre-inst-env guix
> upgrade if they want something locally?
Yes indeed.

Quick update: it is now on gnome-team.

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 47d4c1808f..c9f0349b42 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -258,7 +258,7 @@  (define-public cairo-xcb
 (define-public harfbuzz
   (package
     (name "harfbuzz")
-    (version "5.3.1")
+    (version "8.3.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/harfbuzz/harfbuzz"
@@ -266,7 +266,7 @@  (define-public harfbuzz
                                   version ".tar.xz"))
               (sha256
                (base32
-                "0ka3nkk2lks2lgakq02vyibwdziv11dkpa2brkx230asnyby0v2a"))))
+                "0izq2lpqxrf1l755nxrxkkiarywkx5j43asznankxplbxgm0358h"))))
     (build-system gnu-build-system)
     (outputs '("out"
                "bin"))                  ;160K, only hb-view depend on cairo