diff mbox series

[bug#63355] gnu: kodi: Fix build with latest glibc.

Message ID a0f0c2b5883228e7dcc50cb78274c40580d4ac77.1683520178.git.bavier@posteo.net
State New
Headers show
Series [bug#63355] gnu: kodi: Fix build with latest glibc. | expand

Commit Message

Eric Bavier May 8, 2023, 4:45 a.m. UTC
Currently, kodi's dependency `spdlog`, via spdlog-for-kodi, fails to build,
primarily due to a failure in building its tests; its bundled copy of
"check.h" cannot compile against latest glibc whose `MINSIGSTKSZ` is no
longer a constant.  See e.g. https://github.com/catchorg/Catch2/issues/2178

The `spdlog-for-kodi` variable was added at the same time as the kodi update
to 19.5, but it seems to compile and run fine with the most recent spdlog and
fmt packages, which have been adapted to the glibc change.  Ricardo, do you
recall why this special package was added? or forsee anything wrong with the
change?

`~Eric

* gnu/packages/kodi.scm (kodi)[inputs]: Use most recent 'fmt' and 'spdlog'
packages.
* gnu/packages/logging.scm (spdlog-for-kodi): Delete.
---
 gnu/packages/kodi.scm    |  4 ++--
 gnu/packages/logging.scm | 14 --------------
 2 files changed, 2 insertions(+), 16 deletions(-)


base-commit: 7a0a186a32524d4156bf96786d708fab323cebff

Comments

Ricardo Wurmus May 8, 2023, 6:27 a.m. UTC | #1
Hi Eric,

> Ricardo, do you
> recall why this special package was added? or forsee anything wrong with the
> change?

“No” to both questions.  This looks good to me.
Eric Bavier May 10, 2023, 7:01 p.m. UTC | #2
On Mon, 2023-05-08 at 08:27 +0200, Ricardo Wurmus wrote:
> Hi Eric,
> 
> > Ricardo, do you
> > recall why this special package was added? or forsee anything wrong with the
> > change?
> 
> “No” to both questions.  This looks good to me.
> 

Great, thanks!  This patch was pushed in 7e152870558e.

A follow-up commit in b4e5844700b2 responds to a recent mesa update. 
Probably a kodi update would also have worked, but a backport of the
immediate fix was more expedient.

`~Eric
diff mbox series

Patch

diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index 739d293a57..e0710c9fc2 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -415,7 +415,7 @@  (define-public kodi
            ffmpeg-4
            flac
            flatbuffers
-           fmt-6
+           fmt
            fontconfig
            freetype
            fribidi
@@ -456,7 +456,7 @@  (define-public kodi
            python
            rapidjson
            samba
-           spdlog-for-kodi
+           spdlog
            sqlite
            taglib
            tinyxml
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 550caf7be1..61b3d6ccc5 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -252,20 +252,6 @@  (define-public spdlog-1.10
        (sha256
         (base32 "02xz017ba9fssm1rp1fcfld7h79awbr6fqai9dxaqp02akp3davk"))))))
 
-(define-public spdlog-for-kodi
-  (package
-    (inherit spdlog)
-    (version "1.5.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/gabime/spdlog")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name "spdlog" version))
-       (sha256
-        (base32 "0dn44r3xbw1w0bk9yflnxkh3rzdq2bpxkks44skfmqig0rsj1f1x"))))))
-
 (define-public rsyslog
   (package
     (name "rsyslog")