diff mbox series

[bug#73918,v3,2/2] gnu: yosys: Update to 0.46.

Message ID a0a4c7a7bc05c7e7689168f6b262d6d2a803d227.1731179305.git.csantosb@inventati.org
State New
Headers show
Series Minor corrections to v2 | expand

Commit Message

Cayetano Santos Nov. 9, 2024, 7:08 p.m. UTC
* gnu/packages/fpga.scm (yosys): Update to 0.46.

Change-Id: Id980679e6576b27429611f8399eff2185e57d684
---
 gnu/packages/fpga.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

Comments

Maxim Cournoyer Nov. 12, 2024, 11:40 a.m. UTC | #1
Hello,

Cayetano Santos <csantosb@inventati.org> writes:

> * gnu/packages/fpga.scm (yosys): Update to 0.46.
>
> Change-Id: Id980679e6576b27429611f8399eff2185e57d684

Merged this as 4bfe5fc584 and followed with an update to 0.47.

Closing!
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index ea08aed04c..be3e57ffb4 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2022 Christian Gelinek <cgelinek@radlogic.com.au>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -38,6 +39,7 @@  (define-module (gnu packages fpga)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
@@ -149,15 +151,15 @@  (define-public iverilog
 (define-public yosys
   (package
     (name "yosys")
-    (version "0.26")
+    (version "0.46")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/YosysHQ/yosys")
-                    (commit (string-append "yosys-" version))))
+                    (commit version)))
               (sha256
                (base32
-                "0s79ljgbcfkm7l9km7dcvlz4mnx38nbyxppscvh5il5lw07n45gx"))
+                "1zj7vbpy6v1wn4p5cjs4hdjd467a1j1aj2qhs148bl2s6mzq3p86"))
               (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
@@ -216,6 +218,7 @@  (define-public yosys
            tcl)) ; tclsh for the tests
     (inputs
      (list abc
+           bash-minimal
            graphviz
            gtkwave
            libffi