diff mbox series

[bug#65565] gnu: chaiscript: Fix tests.

Message ID a0905c2eabff02f1b3e9f32a09a033ffc57c74b6.1693139413.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#65565] gnu: chaiscript: Fix tests. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Aug. 27, 2023, 12:30 p.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/cpp.scm (chaiscript)[arguments]: Add fix-tests phase.
---
 gnu/packages/cpp.scm | 9 +++++++++
 1 file changed, 9 insertions(+)


base-commit: 8b4a248fc4765212a4103c4520ae1f901937df41

Comments

Adam Faiz Aug. 27, 2023, 3:09 p.m. UTC | #1
> +    (arguments
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'fix-tests
> +            (lambda _
> +              ;; Its bundled catch2 fails to build with glibc-2.35.
> +              (copy-file #$(file-append catch2 "/include/catch2/catch.hpp")
> +                         "unittests/catch.hpp")))))
Bundling a newer catch2 is not the solution, it's better to delete the bundled header so that it uses the catch2 provided in its inputs.
宋文武 Aug. 29, 2023, 10:46 a.m. UTC | #2
Adam Faiz <adam.faiz@disroot.org> writes:

>> +    (arguments
>> +     (list
>> +      #:phases
>> +      #~(modify-phases %standard-phases
>> +          (add-after 'unpack 'fix-tests
>> +            (lambda _
>> +              ;; Its bundled catch2 fails to build with glibc-2.35.
>> +              (copy-file #$(file-append catch2 "/include/catch2/catch.hpp")
>> +                         "unittests/catch.hpp")))))
> Bundling a newer catch2 is not the solution, it's better to delete the
> bundled header so that it uses the catch2 provided in its inputs.

Um, this copy-file has the same result, it replace the bundled one with
our catch2, anyway I sent a v2 with 'snippet' and 'inputs'.

Thanks.
宋文武 Aug. 31, 2023, 10:06 a.m. UTC | #3
Pushed now, closing!
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3b949198c7..4681963794 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -511,6 +511,15 @@  (define-public chaiscript
        (sha256
         (base32 "0i1c88rn1wwz8nf3dpapcdkk4w623m3nksfy5yjai10k9irkzy3c"))))
     (build-system cmake-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-tests
+            (lambda _
+              ;; Its bundled catch2 fails to build with glibc-2.35.
+              (copy-file #$(file-append catch2 "/include/catch2/catch.hpp")
+                         "unittests/catch.hpp"))))))
     (home-page "https://chaiscript.com/")
     (synopsis "Embedded scripting language designed for C++")
     (description