diff mbox series

[bug#71758,v2] gnu: python-immutables: Update to 0.20.

Message ID a065bbdcd8d28a25953f8a26b53ac41338724fa1.1721156998.git.felgru@posteo.net
State New
Headers show
Series [bug#71758,v2] gnu: python-immutables: Update to 0.20. | expand

Commit Message

Felix Gruber July 16, 2024, 7:09 p.m. UTC
* gnu/packages/python-xyz.scm (python-immutables): Update to 0.20.
  [source]: Use git-fetch as pypi package does not contain test-data
  folder.
  [build-system] Use pyproject-build-system.
  [native-inputs] Add python-setuptools and python-wheel.

Change-Id: I9e7f632a9ff38d1b0f1f3efdb6a7dc0123214536
---
 gnu/packages/python-xyz.scm | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)


base-commit: 325fed4c1514bffd084355455710fcc3f1c8da2c
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a51320d59..ec42993728 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15728,15 +15728,20 @@  (define-public python-xlwt
 (define-public python-immutables
   (package
     (name "python-immutables")
-    (version "0.18")
+    (version "0.20")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "immutables" version))
+       ;; The PyPI package does not contain the test-data directory.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/MagicStack/immutables")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1x4cinh0xbl6p6p2yfm2s07mxxy3lf0zzai9gqpydk4482bwfdjk"))))
-    (build-system python-build-system)
-    (native-inputs (list python-mypy python-pytest))
+        (base32 "047z7xvdkr55c372sn7m3y8762w5kgh5yn1h9gq5qhcnzss04hbw"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-mypy python-pytest python-setuptools python-wheel))
     (home-page "https://github.com/MagicStack/immutables")
     (synopsis "High-performance immutable mapping type for Python")
     (description