diff mbox series

[bug#71869] gnu: glances: Update to 4.1.1.

Message ID a05bfcdad22529e6b5cdfa360e791817e3a06249.1719815527.git.adanskana@gmail.com
State New
Headers show
Series [bug#71869] gnu: glances: Update to 4.1.1. | expand

Commit Message

Ada Stevenson July 1, 2024, 6:35 a.m. UTC
* gnu/packages/python-xyz.scm (glances): Update to 4.1.1.

Change-Id: I4c9a1a59916b922d136e8ceec5984b26aa4f3496
---
 gnu/packages/python-xyz.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: 474b583e7ab0e54947183060024fd4e7181cca28

Comments

jgart July 1, 2024, 7:11 a.m. UTC | #1
Thanks for the patch. Applied!

> -      (uri (pypi-uri "Glances" version))
> +      (uri (pypi-uri "glances" version))

Just a friendly reminder to mention this change in the commit message. I
added it this time.

> -   (list python-defusedxml python-future python-packaging python-psutil python-ujson))
> +   (list python-defusedxml python-orjson python-packaging
> python-psutil))

Just a friendly reminder to mention these dependency changes in the
commit message. I added it this time.
Ada Stevenson July 1, 2024, 7:12 a.m. UTC | #2
Thank you! 

This is my first patch, so thanks for the pointers :)

On 01/07/2024 07:11, jgart <jgart@dismail.de> wrote:
> 
> Thanks for the patch. Applied!
> 
> > -      (uri (pypi-uri "Glances" version))
> > +      (uri (pypi-uri "glances" version))
> 
> Just a friendly reminder to mention this change in the commit message. I
> added it this time.
> 
> > -   (list python-defusedxml python-future python-packaging python-psutil python-ujson))
> > +   (list python-defusedxml python-orjson python-packaging
> > python-psutil))
> 
> Just a friendly reminder to mention these dependency changes in the
> commit message. I added it this time.
> 

Warmly, 
Ada
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ff507e1855..36f75b4b40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22801,13 +22801,13 @@  (define-public python-natsort
 (define-public glances
   (package
   (name "glances")
-  (version "3.4.0.3")
+  (version "4.1.1")
   (source
     (origin
       (method url-fetch)
-      (uri (pypi-uri "Glances" version))
+      (uri (pypi-uri "glances" version))
       (sha256
-        (base32 "0pf8hxbgwkhv8l5frg61b073vscz5a7bz1al7xhn36fvh10xbcg7"))
+        (base32 "10yjwbmwv2x4x1n3hr1631m8l6l9w8fa7rnvfz1vmzkjs199ihib"))
       (modules '((guix build utils)))
       (snippet
        '(begin
@@ -22821,7 +22821,7 @@  (define-public glances
           #t))))
   (build-system python-build-system)
   (propagated-inputs
-   (list python-defusedxml python-future python-packaging python-psutil python-ujson))
+   (list python-defusedxml python-orjson python-packaging python-psutil))
   (home-page "https://github.com/nicolargo/glances")
   (synopsis "Cross-platform curses-based monitoring tool")
   (description