diff mbox series

[bug#50077,v2,2/3] gnu: notmuch: Make cross-compilable.

Message ID a04bd166f196170238fc255d8c4edc10fe4b71f8.1630748355.git.public@yoctocell.xyz
State Accepted
Headers show
Series Improvements to Notmuch | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Sept. 4, 2021, 9:41 a.m. UTC
* gnu/packages/mail.scm (notmuch)[arguments]<#:phases>: Use 'cc-for-target'
  instead of 'gcc'.
---
 gnu/packages/mail.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index eb141c5984..173982cb12 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1358,7 +1358,7 @@  invoking @command{notifymuch} from the post-new hook.")
                         (("/bin/sh") (which "sh")))))
                   (replace 'configure
                     (lambda* (#:key outputs #:allow-other-keys)
-                      (setenv "CC" "gcc")
+                      (setenv "CC" ,(cc-for-target))
                       (setenv "CONFIG_SHELL" (which "sh"))
 
                       (let* ((out (assoc-ref outputs "out"))
@@ -1375,7 +1375,7 @@  invoking @command{notifymuch} from the post-new hook.")
                         (("\\$NOTMUCH_GMIME_X509_CERT_VALIDITY") "0"))))
                   (add-before 'check 'prepare-test-environment
                     (lambda _
-                      (setenv "TEST_CC" "gcc")
+                      (setenv "TEST_CC" ,(cc-for-target))
                       ;; Patch various inline shell invocations.
                       (substitute* (find-files "test" "\\.sh$")
                         (("/bin/sh") (which "sh")))))