diff mbox series

[bug#63639] gnu: password-store: Fix program name in usage and tmpdir.

Message ID a03c745b48e828793352c74235103d12f0e18487.1684740818.git.tobias.kortkamp@gmail.com
State New
Headers show
Series [bug#63639] gnu: password-store: Fix program name in usage and tmpdir. | expand

Commit Message

Tobias Kortkamp May 22, 2023, 7:44 a.m. UTC
* gnu/packages/password-utils.scm (password-store): Fix program name in
usage and tmpdir.
---
 gnu/packages/password-utils.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Hi,

pass from password-store uses the wrong programn name in its usage. The
program name is also used when creating temporary directories/files during
'pass edit'. It doesn't break anything though AFAICT, so this is purely a
cosmetic issue:

#+begin_src
$ pass help
[...]
Usage:
    .pass-real init [--path=subfolder,-p subfolder] gpg-id...
        Initialize new password storage and use gpg-id for encryption.
        Selectively reencrypt existing passwords using new gpg-id.
[...]
#+end_src

Thanks.


base-commit: 849286ba66c96534bddc04df1a47d5692cbc977e

Comments

Nicolas Goaziou July 1, 2023, 11:15 a.m. UTC | #1
Hello,

Tobias Kortkamp <tobias.kortkamp@gmail.com> writes:

> * gnu/packages/password-utils.scm (password-store): Fix program name in
> usage and tmpdir.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index f5f301308a..b4cd866514 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -563,6 +563,12 @@  (define-public password-store
                                  "${PASSWORD_STORE_SYSTEM_EXTENSION_DIR:-"
                                  extension-dir
                                  "}\"\n"))))))
+         (add-before 'install 'patch-program-name
+           ;; Use pass not .pass-real in tmpdir and cmd_usage
+           (lambda _
+             (substitute* "src/password-store.sh"
+               (("^PROGRAM=.*$")
+                "PROGRAM=\"pass\"\n"))))
          (add-before 'install 'patch-passmenu-path
            ;; FIXME Wayland support requires ydotool and dmenu-wl packages
            ;; We are ignoring part of the script that gets executed if