diff mbox series

[bug#68569,v2,1/2] gnu: Add python-apprise.

Message ID a01e58cad9943d713e05012a656efb91059929df.1705867641.git.michaeldelago98@gmail.com
State New
Headers show
Series gnu: borgmatic: Update to 1.8.6 | expand

Commit Message

Mike Delago Jan. 21, 2024, 8:07 p.m. UTC
* gnu/packages/python-xyz.scm (python-apprise): New variable.

Change-Id: I24659780121e3d428002f504a459bea442790a7b
---
 gnu/packages/python-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aebbae1521..223d2e6f58 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14364,6 +14364,44 @@  (define-public python-appdirs
 should be stored on various operating systems.")
     (license license:expat)))
 
+(define-public python-apprise
+  (package
+    (name "python-apprise")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "apprise" version))
+       (sha256
+        (base32 "0nkfv0pyn13lqdr3g3r1dhhnqxkjiayf9pny4m254w04al49shwd"))
+       ;; MacOS tests are failing when attempting to mock terminal-notifier calls.
+       ;; We don't need to test for MacOS support, and removing this file causes
+       ;; tests to succeed.
+       (modules '((guix build utils)))
+       (snippet '(begin
+                   (delete-file-recursively "test/test_plugin_macosx.py")))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-babel
+                         python-coverage
+                         python-flake8
+                         python-pytest
+                         python-pytest-cov
+                         python-pytest-mock
+                         python-pytest-xdist))
+    (propagated-inputs (list python-certifi
+                             python-click
+                             python-markdown
+                             python-pyyaml
+                             python-requests
+                             python-requests-oauthlib))
+    (home-page "https://github.com/caronc/apprise")
+    (synopsis "Push notification library and utility")
+    (description
+     "This module can send notifications to a large number of popular notification
+     services. This package also includes a command line tool for sending
+     notifications through the large number of supported services.")
+    (license license:bsd-2)))
+
 (define-public python-google-pasta
   (package
     (name "python-google-pasta")