diff mbox series

[bug#46366] gnu: Update zfs.

Message ID _hvdoCw7bHSZrJPgytlhM_ghWCUY2yS3YFTK4yxMPNWxzdYCayYtYeKuOyvlKIGpt2BRvr5kBsHIo9HPmLjX3GR4vhc5ifpOkkmzIFcuhh0=@protonmail.com
State Accepted
Headers show
Series [bug#46366] gnu: Update zfs. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

raid5atemyhomework Feb. 7, 2021, 3:18 p.m. UTC
I am fairly unmotivated to continue working on ZFS-on-Guix, but anyway.  Here's an update of ZFS to 2.0.2, at least.

Tested only with `./pre-inst-env guix build zfs` on a patched Guix.  Fairly unmotivated to do more testing since there is no real interest in getting my patches merged.  Posting here just in case somebody actually gets interested.

I have ZFS and Guix on a fileserver I'm using in a homelab for my homework.  It's working for now.  Not really interested in pushing for better ZFS support anymore since I'm tired and need to get on with my homework.


From 566c4aa9104b5866d15c53340d9b68e0960c49bf Mon Sep 17 00:00:00 2001
From: raid5atemyhomework <raid5atemyhomework@protonmail.com>
Date: Sun, 7 Feb 2021 22:47:30 +0800
Subject: [PATCH] gnu: Update zfs.

* gnu/packages/file-systems.scm (zfs): Update to 2.0.2.
---
 gnu/packages/file-systems.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

--
2.30.0

Comments

Léo Le Bouter Feb. 7, 2021, 5:06 p.m. UTC | #1
On Sun, 2021-02-07 at 15:18 +0000, raid5atemyhomework via Guix-patches
via wrote:
> I am fairly unmotivated to continue working on ZFS-on-Guix, but
> anyway.
> Fairly unmotivated to do more testing since there is no real
> interest in getting my patches merged.  Posting here just in case
> somebody actually gets interested.

I am interested by ZFS on GNU Guix but I am not sure I understand
Scheme enough to review your patches. Also, it makes it a bit confusing
that your patches are submitted as several separate bugs. I think it
would make it easier to review if they were all summed into a single
"ZFS on GNU Guix System" bug. Otherwise I think it will take a bit of
patience, I'm sure you've seen the amount of pending patches, we're
near a thousand by now. Lots of things to review, limited time.

All in all, just remember that I am very enthusiastic about ZFS on GNU
Guix! I'm sure lots of people are.
Sharlatan Hellseher Feb. 8, 2021, 12:23 a.m. UTC | #2
Me either!

I've got zfs farm on Proxmox 2x dell servers 10TB each. Guix definitely
benefits of having it on board!
Danny Milosavljevic Feb. 8, 2021, 2:51 a.m. UTC | #3
Hi raid5atemyhomework,

On Sun, 07 Feb 2021 15:18:34 +0000
raid5atemyhomework via Guix-patches via <guix-patches@gnu.org> wrote:

> I am fairly unmotivated to continue working on ZFS-on-Guix, but anyway.  Here's an update of ZFS to 2.0.2, at least.
> 
> Tested only with `./pre-inst-env guix build zfs` on a patched Guix.  Fairly unmotivated to do more testing since there is no real interest in getting my patches merged.  Posting here just in case somebody actually gets interested.
> 
> I have ZFS and Guix on a fileserver I'm using in a homelab for my homework.  It's working for now.  Not really interested in pushing for better ZFS support anymore since I'm tired and need to get on with my homework.

I totally understand.

It's frustrating when well-tested complete patches get unanswered for several
weeks--it happened to me before.

In any case, I've asked whether someone who knows how to create a profile
in a service can finally review your patches.

I'm sorry.

Pushed the update of the zfs package to 2.0.2 to guix master as
commit 5424ca6d6e01672bf7304a4144b05a98852adbab.
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index e6ee645be0..caf190d8ba 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -847,7 +847,7 @@  APFS.")
 (define-public zfs
   (package
     (name "zfs")
-    (version "2.0.1")
+    (version "2.0.2")
     (outputs '("out" "module" "src"))
     (source
       (origin
@@ -856,7 +856,7 @@  APFS.")
                               "/download/zfs-" version
                               "/zfs-" version ".tar.gz"))
           (sha256
-           (base32 "0y3992l4nzr67q18lz1kizw0za1shvqbpmsjz9shv4frh5ihllbi"))))
+           (base32 "090b2pp0cgzkjcnbjf8ms28dah5dff8s04q31z62czapwiy0drdx"))))
     (build-system linux-module-build-system)
     (arguments
      `(;; The ZFS kernel module should not be downloaded since the license