diff mbox series

[bug#72164] linux-libre packaging: Learn to apply deblob script "errata" patches

Message ID Zpho8WL5gCqArpjW@jasmine.lan
State New
Headers show
Series [bug#72164] linux-libre packaging: Learn to apply deblob script "errata" patches | expand

Commit Message

Leo Famulari July 18, 2024, 12:59 a.m. UTC
I tested the build of linux-libre 6.10 with the attached patches, and it
failed as dariqq said it would on #guix, because this kernel series
requires an update to the 'dwarves' package. I'm building again with the
dwarves update now.

https://logs.guix.gnu.org/guix/2024-07-17.log#204228

Also, these errata patches will only be required for 6.10, and not
subsequent releases in this series (6.10.1, etc).

We don't often end up including the mainline release in Guix, but rather
the subsequent stable releases, so in this case, it's not really
necessary to add this functionality. Although it would be nice.
From 3659eaef947623d502708441cfd6531acdc0fd90 Mon Sep 17 00:00:00 2001
Message-ID: <3659eaef947623d502708441cfd6531acdc0fd90.1721264342.git.leo@famulari.name>
From: Leo Famulari <leo@famulari.name>
Date: Wed, 17 Jul 2024 16:05:13 -0400
Subject: [PATCH 1/3] gnu: linux-libre: Add the ability to apply errata patches
 to the deblobbing scripts.

* gnu/packages/linux.scm (linux-libre-deblob-scripts): Accept an optional
parameter DEBLOB-ERRATA-PATCHES.

Change-Id: If3c87f713637428e1cd2eaf5ef962b8005395805
---
 gnu/packages/linux.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)


base-commit: 6cfc88e3be73904fc87443cdd5c7d7961923e848
prerequisite-patch-id: 58efdd6ff2418b91eae89e7964de00b95f83105f
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e5aa712df7..0defc03e7a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -359,9 +359,11 @@  (define-public (system->defconfig system)
 ;;; Kernel source code deblobbing.
 ;;;
 
-(define (linux-libre-deblob-scripts version gnu-revision
+(define* (linux-libre-deblob-scripts version gnu-revision
                                     deblob-hash
-                                    deblob-check-hash)
+                                    deblob-check-hash
+                                    #:optional
+                                    (deblob-errata-patches '()))
   (list (version-major+minor version)
         (origin
           (method url-fetch)
@@ -370,6 +372,8 @@  (define (linux-libre-deblob-scripts version gnu-revision
                               "deblob-" (version-major+minor version)))
           (file-name (string-append "linux-libre-deblob-"
                                     version "-" gnu-revision))
+          (patches
+            (map search-patch deblob-errata-patches))
           (sha256 deblob-hash))
         (origin
           (method url-fetch)