[bug#77827] patch v2

Message ID Z_6TPet57lB3RJhO@kernelpanicroom
State New
Headers
Series [bug#77827] patch v2 |

Commit Message

Jakob Kirsch April 15, 2025, 5:11 p.m. UTC
  oops, forgot to actually add it to LD_LIBRARY_PATH
From eabbb68a8ec9d0c1e5d2a8ab1869f59464b5dc57 Mon Sep 17 00:00:00 2001
Message-ID: <eabbb68a8ec9d0c1e5d2a8ab1869f59464b5dc57.1744737039.git.jakob.kirsch@web.de>
From: Jakob Kirsch <jakob.kirsch@web.de>
Date: Tue, 15 Apr 2025 18:44:58 +0200
Subject: [PATCH v2] gnu: librewolf: Fix video playback.

Firefox seems to enable VAAPI starting with version 137, which depends on libpciaccess.
Without it, video playback randomly stops and doesn't work until you restart the browser.

* gnu/packages/librewolf.scm (librewolf): [inputs]: Add libpciaccess.

Change-Id: I87332f53a41ef64639c9770c6dbfcac1eefe2e84
---
 gnu/packages/librewolf.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)


base-commit: dd947985522886f9de6fdfdde3f0601e42219da5
  

Patch

diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 47ac7c74a2..9a6f51a453 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -558,7 +558,8 @@  (define-public librewolf
                               "libva"
                               "mesa"
                               "pipewire" ; For sharing on Wayland
-                              "pulseaudio")))
+                              "pulseaudio"
+                              "libpciaccess")))
 
                      ;; VA-API is run in the RDD (Remote Data Decoder) sandbox
                      ;; and must be explicitly given access to files it needs.
@@ -574,7 +575,8 @@  (define-public librewolf
                            (delete-duplicates
                             (append-map runpaths-of-input
                                         '("mesa"
-                                          "ffmpeg")))))
+                                          "ffmpeg"
+                                          "libpciaccess")))))
                      (gtk-share (string-append (assoc-ref inputs
                                                           "gtk+")
                                                "/share")))
@@ -661,6 +663,7 @@  (define-public librewolf
                   libgnome
                   libjpeg-turbo
                   libnotify
+                  libpciaccess
                   libpng-apng-for-librewolf
                   libva
                   libvpx