[bug#67495] gnu: add package ocaml-tsort
Commit Message
From cdf5a9ef1a241fa6b8d13ada5d8ad5705b6efd79 Mon Sep 17 00:00:00 2001
Message-ID: <cdf5a9ef1a241fa6b8d13ada5d8ad5705b6efd79.1701114505.git.gabriel.hondet@cominety.net>
From: Gabriel Hondet <gabriel.hondet@cominety.net>
Date: Mon, 27 Nov 2023 20:46:51 +0100
Subject: [PATCH] [PATCH] gnu: add package ocaml-tsort
Change-Id: I659433d73e1f43e58844f432b9d1d8e1d3047bb7
---
gnu/packages/ocaml.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
base-commit: b150c546b04c9ebb09de9f2c39789221054f5eea
@@ -5207,6 +5207,27 @@ (define-public ocaml-graph
(description "OCamlgraph is a generic graph library for OCaml.")
(license license:lgpl2.1)))
+(define-public ocaml-tsort
+ (package
+ (name "ocaml-tsort")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dmbaturin/ocaml-tsort")
+ (commit "2.1.0")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07m88nxb9w6wv64h18xyz7js6flpglkk5c8lhs8wgh46r13p89s8"))))
+ (build-system dune-build-system)
+ (home-page "https://github.com/dmbaturin/ocaml-tsort")
+ (synopsis "Easy to use and user-friendly topological sort")
+ (description
+ "Easy to use and user-friendly topological sort. Example: @code{Tsort.sort
+[(\"foundation\", []); (\"walls\", [\"foundation\"]); (\"roof\", [\"walls\"])]}")
+ (license license:expat)))
+
(define-public ocaml-piqi
(package
(name "ocaml-piqi")