diff mbox series

[bug#66257] Add python-icmplib.

Message ID ZR0P278MB0268A9B1B8810E9F597D186AC1C1A@ZR0P278MB0268.CHEP278.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#66257] Add python-icmplib. | expand

Commit Message

Wicki Gabriel (wicg) Sept. 28, 2023, 12:34 p.m. UTC
Add the python equivalent of the ICMP utilities (ping and similar).

--
Gabriel Wicki
Research Assistant

ZHAW, Zurich University of Applied Sciences
InES, Institute of Embedded Systems
High Integrity Systems Group

Technikumstrasse 22, Postfach
CH-8401 Winterthur
--
E-Mail: wicg@zhaw.ch
Web: http://ines.zhaw.ch

Comments

Mathieu Othacehe Oct. 14, 2023, 1:36 p.m. UTC | #1
> +(define-public python-icmplib

Applied, thanks,

Mathieu
diff mbox series

Patch

From 8a28765a75fd4459056c2d3baace28d9a2e5ced4 Mon Sep 17 00:00:00 2001
Message-ID: <8a28765a75fd4459056c2d3baace28d9a2e5ced4.1695904452.git.wicg@zhaw.ch>
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Thu, 28 Sep 2023 14:25:44 +0200
Subject: [PATCH] gnu: Add python-icmplib.

* gnu/packages/python-xyz.scm (python-icmplib): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index be03c2a7da..18660ebf20 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1802,6 +1802,28 @@  (define-public python-scapy
 attacks or network discovery.")
     (license license:gpl2)))
 
+(define-public python-icmplib
+  (package
+    (name "python-icmplib")
+    (version "3.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "icmplib" version))
+       (sha256
+        (base32 "1yssh1bsymlcwmvfag47wg1x9axl6i0zwzywxv1abzz0ndmdmyz4"))))
+    (arguments
+     '(#:tests? #f)) ;test data not present
+    (build-system python-build-system)
+    (home-page "https://github.com/ValentinBELYN/icmplib")
+    (synopsis
+     "Python implementation of the Internet Control Message Protocol (ICMP)")
+    (description
+     "@code{icmplib} is a supporting library for both IPv4 and IPv6 networks.
+ICMP is typically used for diagnostic or control purposes - well known from
+utilities such as ping(1).")
+    (license license:lgpl3)))
+
 (define-public python-rasterio
   (package
     (name "python-rasterio")

base-commit: 3963fa1a465708690cd1554d911613f1c92f5eef
-- 
2.41.0