[bug#64504] gnu: Add unsio.
Commit Message
Hello,
thanks for the patch! I tried to remove the marketing speech out of the
description. For the #:build-type, the default value (release with debug
information) also works and results in a package of the same size. Is there
a reason to change it? Modified patch attached.
I can also compile the package without the configure flags, are they
useful?
In the end dynamic and static libraries end up in a directory lib64/.
Should this not be lib/?
And there are lots of warnings about 34 bit shifts in a 32 bit type.
But I suppose you tested that the library works.
Andreas
From f5401b0abbe58aa473738dc58d541e2bece9db65 Mon Sep 17 00:00:00 2001
Message-ID: <f5401b0abbe58aa473738dc58d541e2bece9db65.1691486728.git.andreas@enge.fr>
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Thu, 6 Jul 2023 23:13:05 +0100
Subject: [PATCH] gnu: Add unsio.
* gnu/packages/astronomy.scm (unsio): New variable.
Co-Authored-By: Iliya Tikhonenko <tikhonenko@mpe.mpg.de>
Signed-off-by: Andreas Enge <andreas@enge.fr>
---
gnu/packages/astronomy.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
base-commit: f19736e62f9ab5fba0ac5fe184a221c2a5d374c6
Comments
Hello!
I am the author of the initial version of this patch (kudos to Sharlatan
for cleaning it up and bringing to guix proper!)
On 8/8/23 11:29, Andreas Enge wrote:
> For the #:build-type, the default value (release with debug information) also works and results in a package of the same size. Is there a reason to change it? Modified patch attached.
The debug build type is unnecessary verbose (see src/uns.cc line 71-73
for an example) to the point that it impacts performance sometimes,
which is important considering the usecase of the library.
> I can also compile the package without the configure flags, are they useful?
Checked again, I still cannot compile it without -DCMAKE_CXX_STANDARD=14
> And there are lots of warnings about 34 bit shifts in a 32 bit type.
> But I suppose you tested that the library works.
I have not noticed any issues using it during the past two years, but
this cannot be considered a proper test because I am actually using a
small subset of the library. Perhaps, this warning should be reported
upstream, thanks!
All the best,
Iliya
@@ -9,6 +9,7 @@
;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2023 Iliya Tikhonenko <tikhonenko@mpe.mpg.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
@@ -3951,3 +3953,32 @@ (define-public python-wiimatch
for optimal @code{matching} of weighted N-dimensional image intensity data
using (multivariate) polynomials.")
(license license:bsd-3)))
+
+(define-public unsio
+ ;; There is no versioned tag, use the latest commit.
+ (let ((commit "25e52468298e1194c9726ef5dba9d5fbb46870f5")
+ (revision "0"))
+ (package
+ (name "unsio")
+ (version (git-version "1.3.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.lam.fr/infrastructure/unsio")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "110i2p5608zhh5w3pf3b5r2651hykw2ayspgq6vpqsffhya1p170"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;No tests
+ #:configure-flags #~(list "-DCMAKE_CXX_STANDARD=14")))
+ (inputs (list gfortran hdf5 perl sqlite zlib))
+ (home-page "https://projets.lam.fr/projects/unsio/wiki")
+ (synopsis "Input and output routines for n-body file formats")
+ (description
+ "@acronym{UNSIO, Universal Nbody Snapshot Input Output} provides
+an API for performing input and output operations on different kinds of
+n-body file formats (nemo, Gadget binaries 1 and 2, Gadget hdf5, Ramses).")
+ (license license:cecill))))