[bug#64688,v4] gnu: Add calc.
Commit Message
Hello,
as there has been a new stable release in the meantime, I updated to this.
I also simplified the package a bit, maybe due to the new release one
substitute did not apply any more, another one did not seem to be necessary
regardless, and several "substitute*" on the same file can be combined into
one expression. I then set PREFIX and used it in a substitution, which
makes some CFLAGS unnecessary, and others are there by default in the
current Makefile. Finally I made the description a bit more neutral.
The resulting calc binary seems to work, if you are happy with the
package, I could push it.
Andreas
From e73a154f281e81f9c2bb9c4655dada1ef7df0e48 Mon Sep 17 00:00:00 2001
Message-ID: <e73a154f281e81f9c2bb9c4655dada1ef7df0e48.1690364856.git.andreas@enge.fr>
From: Distopico <distopico@riseup.net>
Date: Mon, 24 Jul 2023 10:31:24 -0500
Subject: [PATCH] gnu: Add calc.
* gnu/packages/maths.scm (calc): New variable.
Co-authored-by: Andreas Enge <andreas@enge.fr>
---
gnu/packages/maths.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
base-commit: 713dca1399cda2439af75989510f86718741a4ff
Comments
Tested, works fine from my side, thank you
On 2023-07-26, Andreas Enge <andreas@enge.fr> wrote:
> Hello,
>
> as there has been a new stable release in the meantime, I updated to this.
> I also simplified the package a bit, maybe due to the new release one
> substitute did not apply any more, another one did not seem to be necessary
> regardless, and several "substitute*" on the same file can be combined into
> one expression. I then set PREFIX and used it in a substitution, which
> makes some CFLAGS unnecessary, and others are there by default in the
> current Makefile. Finally I made the description a bit more neutral.
>
> The resulting calc binary seems to work, if you are happy with the
> package, I could push it.
>
> Andreas
>
> [2. text/plain; 0001-gnu-Add-calc.patch]...
Am Wed, Jul 26, 2023 at 09:27:20AM -0500 schrieb Distopico:
> Tested, works fine from my side, thank you
Excellent, pushed! Closing this bug.
Andreas
@@ -60,6 +60,7 @@
;;; Copyright © 2022 Akira Kyle <akira@akirakyle.com>
;;; Copyright © 2022 Roman Scherer <roman.scherer@burningswell.com>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -261,6 +262,39 @@ (define-public c-graph
(license license:gpl3+)
(home-page "https://www.gnu.org/software/c-graph/")))
+(define-public calc
+ (package
+ (name "calc")
+ (version "2.14.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.isthe.com/chongo/src/calc/calc-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0kg7cqhq70dlj7k8mrl0dbps1yvflfhri7c1gvm9nh4g2adlkxkf"))))
+ (build-system gnu-build-system)
+ (inputs (list readline))
+ (native-inputs (list util-linux)) ; for col
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'patch-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("^PREFIX= /usr/local")
+ (string-append "PREFIX=" #$output))
+ (("=\\s?/usr")
+ "= ${PREFIX}")))))))
+ (synopsis "Arbitrary precision console calculator")
+ (description
+ "Calc is an arbitrary precision arithmetic system that uses a C-like
+language. It can be used as a calculator, an algorithm prototyper and as
+a mathematical research tool, and it comes with built in mathematical and
+programmatic functions.")
+ (home-page "http://www.isthe.com/chongo/tech/comp/calc/")
+ (license license:lgpl2.1)))
+
(define-public coda
(package
(name "coda")