diff mbox series

[bug#63964] Acknowledgement ([PATCH] gnu: Add kineto.)

Message ID ZIStCiCQgnGDmhft@theoden
State New
Headers show
Series [bug#63964] Acknowledgement ([PATCH] gnu: Add kineto.) | expand

Commit Message

Christopher Howard June 10, 2023, 5:04 p.m. UTC
Someone on IRC asked me to makes some changes to the description. Here is a new patch.

Comments

Christopher Howard June 23, 2023, 6:53 p.m. UTC | #1
I just want to mention that the package builds easily without any issues.
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3af4aa0b8d..3969ff4605 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -62,6 +62,7 @@ 
 ;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
 ;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
+;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8502,6 +8503,36 @@  (define-public vger
 @command{stunnel} on @command{inetd}.")
     (license license:bsd-2)))
 
+(define-public kineto
+  (package
+    (name "kineto")
+    (version "0.0.0-20211105093215-857f8c97ebc5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~sircmpwn/kineto")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1r17c904i76yy5ilvhjczmhnq5g7r4nkjwmsjcfxcqzly0ia7m2k"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "git.sr.ht/~sircmpwn/kineto/"))
+    (propagated-inputs `(("go-git-sr-ht-sircmpwn-getopt"
+                          ,go-git-sr-ht-sircmpwn-getopt)
+                         ("go-git-sr-ht-adnano-go-gemini"
+                          ,go-git-sr-ht-adnano-go-gemini)))
+    (home-page "https://git.sr.ht/~sircmpwn/kineto/")
+    (synopsis "HTTP proxy for Gemini")
+    (description
+     "This is an @acronym{HTTP} to
+@url{https://gemini.circumlunar.space/,Gemini} proxy designed to provide
+service for a single domain, i.e.  to make your Gemini site available over
+HTTP.  It can proxy to any domain in order to facilitate linking to the rest
+of Geminispace, but it defaults to a specific domain.")
+    (license license:gpl3)))
+
 (define-public libzim
   (package
     (name "libzim")