[bug#75386] gnu: tinmop: Update to 0.9.9.1414213562373.
Commit Message
Change-Id: Ib8eca6b1b6f36ca7bfdb7209605715be7215be76
---
gnu/packages/web-browsers.scm | 24 ++++++++++++++++++------
1 file changed, 18 insertions(+), 6 deletions(-)
Comments
Pushed to master as commit 1e467c0fe5, thank you!
> Pushed to master as commit 1e467c0fe5, thank you!
>
Thank you very much to you for your work! :)
C.
@@ -864,7 +864,7 @@ (define-public bombadillo
(define-public tinmop
(package
(name "tinmop")
- (version "0.9.9.14142135623")
+ (version "0.9.9.1414213562373")
(source
(origin
(method git-fetch)
@@ -873,20 +873,23 @@ (define-public tinmop
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "02kp527gyh60fm2ss92wy3k3m9fih82wvzndri98sj2zc0wgcnki"))))
+ (base32 "1grcngb6rnyzkdkf52m62m1kmd8nxm9m85bpg2py5mp3ghf5y5gp"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
automake
+ bash-completion
gnu-gettext
libjpeg-turbo
imagemagick
mandoc
nano
openssl
+ pkg-config
sbcl
tk
unzip
+ which
xdg-utils))
(inputs
(list ncurses
@@ -913,7 +916,6 @@ (define-public tinmop
sbcl-log4cl
sbcl-marshal
sbcl-nodgui
- sbcl-osicat
sbcl-parse-number
sbcl-percent-encoding
sbcl-purgatory
@@ -924,6 +926,7 @@ (define-public tinmop
sbcl-unix-opts
sbcl-usocket
sbcl-yason
+ sdl2-ttf
sqlite))
(arguments
`(#:tests? #f
@@ -943,14 +946,23 @@ (define-public tinmop
(("AC_PATH_PROGS.+GIT")
"dnl")
(("AC_PATH_PROG.+GPG")
- "dnl"))
+ "dnl")
+ (("AC_PATH_PROG.+SDL2")
+ "dnl ")
+ (("AC_CHECK_HEADER.+ttf")
+ "dnl "))
+ (substitute* "Makefile.am"
+ (("dist_completion_DATA")
+ "#")
+ (("completiondir")
+ "#"))
#t))
(add-after 'configure 'fix-asdf
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile.in"
- (("LISP_COMPILER) ")
+ (("--dynamic-space-size $(DYNAMIC_MEMORY_SIZE)")
(string-concatenate
- '("LISP_COMPILER) --eval \"(require 'asdf)\" "
+ '("--dynamic-space-size $(DYNAMIC_MEMORY_SIZE) "
"--eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))))
#t)))))
(synopsis