[bug#75036] : Update hyprland to 0.46.2
Commit Message
This bumps hyprland and related packages to the newest version.
committer.scm is broken with this patch so someone would have to fix that.
From b89005e583c345708fe80a1c8bd7cd4a7bd74edd Mon Sep 17 00:00:00 2001
Message-ID: <b89005e583c345708fe80a1c8bd7cd4a7bd74edd.1734905531.git.jakob.kirsch@web.de>
From: Jakob Kirsch <jakob.kirsch@web.de>
Date: Sun, 22 Dec 2024 23:11:46 +0100
Subject: [PATCH v1] Bump hyprland to 0.46.2
please fill in the appropriate stuff here as committer.scm is broken
Change-Id: I722b85de3e7b68eb5afdc55dfe2c3d0ccec5db58
---
gnu/packages/cpp.scm | 32 ++++++++++++++++++++++++++++++--
gnu/packages/wm.scm | 8 ++++++--
gnu/packages/xdisorg.scm | 5 +++--
3 files changed, 39 insertions(+), 6 deletions(-)
base-commit: f63c81d8af46ee7738ddb9678ef4db7a6b6e3287
--
2.46.0
Comments
Hi Jakob,
On Sun, Dec 22, 2024 at 11:22 PM, Jakob Kirsch wrote:
> This bumps hyprland and related packages to the newest version.
Great, thanks! Was just about to do the updates when I figured to search
if anyone had done it already.
I split these up into separate commits (one add/update per commit),
alphabetized and reformated the inputs for hyprgraphics, and did the
relevant commit changelogs. All were easy, just needed to specify the
input changes for hyprland.
See commits:
<https://git.savannah.gnu.org/cgit/guix.git/commit/?id=c3ab9a16b746c9f8e10ec3721b3555f10efd1ab0>
<https://git.savannah.gnu.org/cgit/guix.git/commit/?id=7e61bf78fa44299c6375f4577d1c5a02a8844596>
<https://git.savannah.gnu.org/cgit/guix.git/commit/?id=9a36d48e11c93b8d77abc62a3a1368d74671f681>
<https://git.savannah.gnu.org/cgit/guix.git/commit/?id=ce44a0922979d2ade902638afb9b0d28b160def0>
for details for your future reference.
> committer.scm is broken with this patch so someone would have to fix
> that.
I guess I don't use that file or at least not explicitly (no problems
here). If you, or someone, haven't already, please submit a bug
report/patch.
Thanks again!
John
Looks like we missed a (partly?) optional dependency during the upgrade to 0.46.2. Namely, when I boot hyprland@0.46.2 after updating, I see the following warning when hyprland boots:
--8<---------------cut here---------------start------------->8---
Your system does not have hyprland-qtutils installed. This is a runtime dependency for some dialogs. Consider installing it.
--8<---------------cut here---------------end--------------->8---
This is coming from https://github.com/hyprwm/Hyprland/blob/v0.46.2/src/Compositor.cpp#L2637
Seems like we should also package https://github.com/hyprwm/hyprland-qtutils (a little c++ library) and include it as an input of the hyprland package.
Thanks for the update to Hyprland.
PS: imo, this doesn't seem urgent enough to revert; I think we can just fix forward.
Hi Collin,
On Thu, Jan 02, 2025 at 03:01 PM, Collin J. Doering wrote:
> Looks like we missed a (partly?) optional dependency during the
> upgrade to 0.46.2. Namely, when I boot hyprland@0.46.2 after updating,
> I see the following warning when hyprland boots:
>
> --8<---------------cut here---------------start------------->8---
> Your system does not have hyprland-qtutils installed. This is a
> runtime dependency for some dialogs. Consider installing it.
> --8<---------------cut here---------------end--------------->8---
>
> This is coming from
> <https://github.com/hyprwm/Hyprland/blob/v0.46.2/src/Compositor.cpp#L2637>
>
> Seems like we should also package
> <https://github.com/hyprwm/hyprland-qtutils> (a little c++ library) and
> include it as an input of the hyprland package.
>
> Thanks for the update to Hyprland.
>
> PS: imo, this doesn't seem urgent enough to revert; I think we can just fix forward.
Thanks for pointing this out as I hadn't tried the update in my system yet. I just opened a patch to add the missing package and use it in Hyprland, and you should have received that directly as I added you on the CC.
John
@@ -41,6 +41,7 @@
;;; Copyright © 2023-2024 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Peepo Froggings <peepofroggings@tutanota.de>
+;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
;;; This file is part of GNU Guix.
;;;
@@ -95,6 +96,7 @@ (define-module (gnu packages cpp)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libunwind)
@@ -665,6 +667,32 @@ (define-public google-highway
library for SIMD (Single Instruction, Multiple Data) with runtime dispatch.")
(license license:asl2.0)))
+(define-public hyprgraphics
+ (package
+ (name "hyprgraphics")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hyprwm/hyprgraphics")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet #~(substitute* "CMakeLists.txt" (("libjxl_cms") "")))
+ (sha256
+ (base32
+ "19vk1c1hli5921ai3ik6pbyixih7fhn1010injxi8dpjak6cjlhl"))))
+ (build-system cmake-build-system)
+ (native-inputs (list gcc-14 pkg-config))
+ (arguments (list #:cmake cmake-3.30))
+ (inputs (list pixman cairo hyprutils libjpeg-turbo libwebp libjxl))
+ (home-page "https://wiki.hyprland.org/Hypr-Ecosystem/hyprgraphics/")
+ (synopsis "Hyprland graphics / resource utilities ")
+ (description
+ "Hyprgraphics is a small C++ library with graphics / resource related
+utilities used across the hypr* ecosystem.")
+ (license license:bsd-3)))
+
(define-public hyprlang
(package
(name "hyprlang")
@@ -702,7 +730,7 @@ (define-public hyprlang
(define-public hyprutils
(package
(name "hyprutils")
- (version "0.2.3")
+ (version "0.2.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -711,7 +739,7 @@ (define-public hyprutils
(file-name (git-file-name name version))
(sha256
(base32
- "01dh24rf62gb6xm32f7mfv6wx0dxprr1q9y73hvv7xanrjyia2zn"))))
+ "0scrfky9hkzhbyj5aji6qvi4b6ydf4g7sk0cknkpd7dg0zv8x5zq"))))
(build-system cmake-build-system)
(arguments
(list
@@ -77,6 +77,7 @@
;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
+;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -168,6 +169,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages regex)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages suckless)
@@ -323,7 +325,7 @@ (define-public herbstluftwm
(define-public hyprland
(package
(name "hyprland")
- (version "0.45.2")
+ (version "0.46.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/hyprwm/Hyprland"
@@ -340,7 +342,7 @@ (define-public hyprland
"subprojects"))))
(sha256
(base32
- "1jqnly8h72v20fsz1075ib7gl7272g5svqw7qpqhx6243w1320np"))))
+ "1hdhk7skf94nm4kk3zs2vqyi0qlc32hb7gfhlyzawj5wq05bawnh"))))
(build-system cmake-build-system)
(arguments
(list #:cmake cmake-3.30
@@ -373,6 +375,7 @@ (define-public hyprland
binutils
cairo
hyprcursor
+ hyprgraphics
hyprland-protocols
hyprlang
hyprutils
@@ -382,6 +385,7 @@ (define-public hyprland
mesa
pango
pciutils
+ re2-next
udis86
wayland
wayland-protocols
@@ -65,6 +65,7 @@
;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Spencer Peters <spencerpeters@protonmail.com>
+;;; Copyright © 2024 Jakob Kirsch <jakob.kirsch@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -237,7 +238,7 @@ (define-public xvkbd
(define-public aquamarine
(package
(name "aquamarine")
- (version "0.4.3")
+ (version "0.5.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -246,7 +247,7 @@ (define-public aquamarine
(file-name (git-file-name name version))
(sha256
(base32
- "0x1zz1ywchs0awkjkvdgskgqnp6pz5lqwmgr8g0zc0i7inhyg1p3"))))
+ "0m4yjpdkp8czfn897376d0pjba3l5iwfj1b9rv44p37r7j8za6qv"))))
(build-system cmake-build-system)
(arguments
(list #:cmake cmake-3.30