[bug#55901,v2] gnu: Add lis.
Commit Message
Am Wed, Mar 26, 2025 at 02:08:38PM +0100 schrieb Liliana Marie Prikler:
> > The patch looks good, I have made a small modification to avoid the
> > assoc-ref, see attached. Please feel free to push.
> Did you send the right file? It lools like the assoc-ref is still
> there. I know we could use #$output, but I don't feel too strongly
> about it. WDYT?
Ah, sorry, I had probably forgotten to commit the local changes. Here it is.
I would say that #$output goes together with all the "modernising" changes
to packaging such as gexps, not using assoc-ref, not ending a phase with #t,
so I would prefer it.
Andreas
From afb324e09ff086d330ef9b667ee24bd9c9e832cc Mon Sep 17 00:00:00 2001
Message-ID: <afb324e09ff086d330ef9b667ee24bd9c9e832cc.1742996532.git.andreas@enge.fr>
From: Liliana Marie Prikler <liliana.prikler@gmail.com>
Date: Sat, 11 Jun 2022 09:49:23 +0200
Subject: [PATCH] gnu: Add lis.
* gnu/packages/maths.scm (lis): New variable.
Change-Id: I68bf93787346815912d02b919cb5c9acf884483e
---
gnu/packages/maths.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
base-commit: 0c83bcfa812f49d5d8c91255548aad46ef3bfcb6
Comments
Am Mittwoch, dem 26.03.2025 um 14:44 +0100 schrieb Andreas Enge:
> Am Wed, Mar 26, 2025 at 02:08:38PM +0100 schrieb Liliana Marie
> Prikler:
> > > The patch looks good, I have made a small modification to avoid
> > > the
> > > assoc-ref, see attached. Please feel free to push.
> > Did you send the right file? It lools like the assoc-ref is still
> > there. I know we could use #$output, but I don't feel too strongly
> > about it. WDYT?
>
> Ah, sorry, I had probably forgotten to commit the local changes. Here
> it is. I would say that #$output goes together with all the
> "modernising" changes to packaging such as gexps, not using assoc-
> ref, not ending a phase with #t, so I would prefer it.
Fair enough.
Pushed with these changes.
@@ -1198,6 +1198,45 @@ (define-public lapack
"See LICENSE in the distribution."))
(properties '((tunable? . #t)))))
+(define-public lis
+ (package
+ (name "lis")
+ (version "2.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.ssisc.org/lis/dl/lis-"
+ version ".zip"))
+ (sha256
+ (base32 "0nh2593xkcdv1c3gmj7i64ca393nn0ngqfl522yiwbidh9dvd1nl"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "--enable-fortran"
+ "--enable-f90"
+ "--enable-openmp"
+ "--enable-complex"
+ "--disable-sse2" ;; XXX: tuning
+ "--enable-shared")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda _
+ (let* ((share (string-append #$output "/share"))
+ (docdir (string-append share "/doc/lis-" #$version))
+ (mandir (string-append share "/man")))
+ (copy-recursively "doc/man" mandir)
+ ;; TODO: Build the manuals ourselves
+ (install-file "doc/lis-ug-en.pdf" docdir)
+ (install-file "doc/lis-ug-ja.pdf" docdir)))))))
+ (inputs (list openmpi))
+ (native-inputs (list gfortran unzip))
+ (home-page "https://www.ssisc.org/lis")
+ (synopsis "Solve discretized linear equations and eigenvalue problems")
+ (description "Lis is a parallel software library for solving discretized
+linear equations and eigenvalue problems that arise in the numerical solution
+of partial differential equations using iterative methods.")
+ (license license:bsd-3)))
+
(define-public clapack
(package
(name "clapack")