[bug#55901,v2] gnu: Add lis.
Commit Message
Hi again,
your new message was dated to 2022, which is a bit surprising :)
The patch looks good, I have made a small modification to avoid the
assoc-ref, see attached. Please feel free to push.
The project itself has a strange organisation: Their git repo is on
github, but there the tags stop at version 2.0.30, and latest releases
exist only as zip files (while they had tar.gz files in the past).
Andreas
From d6867665c2f2d0c35d236b7709bfbfd6ac8d0aac Mon Sep 17 00:00:00 2001
Message-ID: <d6867665c2f2d0c35d236b7709bfbfd6ac8d0aac.1742992715.git.andreas@enge.fr>
From: Liliana Marie Prikler <liliana.prikler@gmail.com>
Date: Sat, 11 Jun 2022 09:49:23 +0200
Subject: [PATCH] gnu: Add lis.
* gnu/packages/maths.scm (lis): New variable.
---
gnu/packages/maths.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)
base-commit: 0c83bcfa812f49d5d8c91255548aad46ef3bfcb6
Comments
Am Mittwoch, dem 26.03.2025 um 13:41 +0100 schrieb Andreas Enge:
> your new message was dated to 2022, which is a bit surprising :)
Yeah, I did not reset the author date.
> The patch looks good, I have made a small modification to avoid the
> assoc-ref, see attached. Please feel free to push.
Did you send the right file? It lools like the assoc-ref is still
there. I know we could use #$output, but I don't feel too strongly
about it. WDYT?
Cheers
@@ -1198,6 +1198,46 @@ (define-public lapack
"See LICENSE in the distribution."))
(properties '((tunable? . #t)))))
+(define-public lis
+ (package
+ (name "lis")
+ (version "2.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.ssisc.org/lis/dl/lis-"
+ version ".zip"))
+ (sha256
+ (base32 "0nh2593xkcdv1c3gmj7i64ca393nn0ngqfl522yiwbidh9dvd1nl"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "--enable-fortran"
+ "--enable-f90"
+ "--enable-openmp"
+ "--enable-complex"
+ "--disable-sse2" ;; XXX: tuning
+ "--enable-shared")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (docdir (string-append out "/share/doc/lis-" #$version))
+ (mandir (string-append out "/share/man")))
+
+ (copy-recursively "doc/man" mandir)
+ ;; TODO: Build the manuals ourselves
+ (install-file "doc/lis-ug-en.pdf" docdir)
+ (install-file "doc/lis-ug-ja.pdf" docdir)))))))
+ (inputs (list openmpi))
+ (native-inputs (list gfortran unzip))
+ (home-page "https://www.ssisc.org/lis")
+ (synopsis "Solve discretized linear equations and eigenvalue problems")
+ (description "Lis is a parallel software library for solving discretized
+linear equations and eigenvalue problems that arise in the numerical solution
+of partial differential equations using iterative methods.")
+ (license license:bsd-3)))
+
(define-public clapack
(package
(name "clapack")