diff mbox series

[bug#50838] Update sbcl

Message ID Z-2xLZ6o5fxTIJvKOam2LuyZLUb8zqv6DLlgNsLf-mK_MzG0sQtcXSk5mqsdu81ehF3V8T_80txQMEHP5ivKprtjCL_zM5bl3n6Xg836ep8=@protonmail.com
State Accepted
Headers show
Series [bug#50838] Update sbcl | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles Sept. 27, 2021, 5:51 a.m. UTC
Empty Message

Comments

Guillaume Le Vaillant Sept. 27, 2021, 12:32 p.m. UTC | #1
Hi,

Some time ago when Pierre Neidhardt tried to update SBCL to 2.1.7, some
packages failed to compile (because of changes in the internals of SBCL
I think). See commits b07581d6e24bf5fa4676bcebaba75315bbbb01e6 and
7c6ace67bb8ef421965e3f1cc1a02caf54c813f5.

Did you try building all the sbcl-* packages with SBCL 2.1.8 to check if
everything works fine?
If some packages are failing, we will have to update them as well
(upstreams probably have commits or PRs to fix compatibility with newer
SBCL versions).
Charles Sept. 27, 2021, 7:45 p.m. UTC | #2
I built all sbcl-* packages, I used this snippet to build them; let me know if there is a better way.

./pre-inst-env guix build $(./pre-inst-env guix search "^name: sbcl-" | awk '{ print $2 }' | tr '\n' ' ')

sbcl-burgled-batteries3 fails to build. It also fails on sbcl 2.1.6. Perhaps people are not really using the sbcl version of this package and just using the ecl version as it builds fine. I'm not sure how the build system works for cl- packages, but apparently it uses sbcl too.

Same story with sbcl-png.

These are the only two offenders; all other packages built fine.
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Monday, September 27th, 2021 at 7:32 AM, Guillaume Le Vaillant <glv@posteo.net> wrote:

> Hi,
>
> Some time ago when Pierre Neidhardt tried to update SBCL to 2.1.7, some
>
> packages failed to compile (because of changes in the internals of SBCL
>
> I think). See commits b07581d6e24bf5fa4676bcebaba75315bbbb01e6 and
>
> 7c6ace67bb8ef421965e3f1cc1a02caf54c813f5.
>
> Did you try building all the sbcl-* packages with SBCL 2.1.8 to check if
>
> everything works fine?
>
> If some packages are failing, we will have to update them as well
>
> (upstreams probably have commits or PRs to fix compatibility with newer
>
> SBCL versions).
diff mbox series

Patch

From 738370cd57bdb5874378797811f87dd7dafbab78 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Mon, 27 Sep 2021 00:43:17 -0500
Subject: [PATCH] gnu: sbcl: Update to 2.1.8.

* gnu/packages/lisp.scm (sbcl): Update to 2.1.8.
---
 gnu/packages/lisp.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 7eb8f54d49..c924880ac9 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -404,14 +404,14 @@  an interpreter, a compiler, a debugger, and much more.")
 (define-public sbcl
   (package
     (name "sbcl")
-    (version "2.1.6")
+    (version "2.1.8")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
                            version "-source.tar.bz2"))
        (sha256
-        (base32 "1vydq6mmssla2vn0plpsrm50n3b42a464zxw72j6qihas9fhq8cb"))))
+        (base32 "0ijmw8adyf6fgaq4ixdj9v5lfg3cs9wyxhb96wxhfld0rjpppsm3"))))
     (build-system gnu-build-system)
     (outputs '("out" "doc"))
     (native-inputs
-- 
2.32.0