diff mbox series

[bug#57300] gnu: Add xssstate.

Message ID Yv/FFpSiXlQuRfPP@sax.terramar.selidor.net
State New
Headers show
Series [bug#57300] gnu: Add xssstate. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ivan Vilata i Balaguer Aug. 19, 2022, 5:15 p.m. UTC
Hi!  The attached patch adds the [xssstate][1] package from the Suckless
suite.  It can be used in scripts to get information about the X screen saver,
like idle time, current state, and time until activation.

[1]: https://tools.suckless.org/x/xssstate/

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index dbc3537ac6..bc0961942b 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
+;;; Copyright © 2022 Ivan Vilata i Balaguer <ivan@selidor.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1217,3 +1218,31 @@  (define-public svkbd
     (description "svkbd is a simple virtual keyboard, intended to be used in
 environments, where no keyboard is available.")
     (license license:expat)))
+
+(define-public xssstate
+  (package
+    (name "xssstate")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://dl.suckless.org/tools/xssstate-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "04b03jz38pn5qhddg8a9hh01qqzrrdjvsq09qrxj9sx8lq2gbdn4"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:make-flags (list (string-append "CC="
+                                         ,(cc-for-target))
+                          (string-append "PREFIX=" %output))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure))))
+    (inputs (list libxscrnsaver))
+    (home-page "https://tools.suckless.org/x/xssstate/")
+    (synopsis "A simple tool to retrieve the X screensaver state")
+    (description
+     "This is a simple utility to get the state of the X screensaver extension.
+These states include the idle time, the screensaver state and the time how
+long to wait until the screensaver should be active.")
+    (license license:x11)))