diff mbox series

[bug#55868] gnu: r-prereg: Add TeXLive dependencies.

Message ID YqHnDTf60Aq3QrpR@noor.fritz.box
State Accepted
Headers show
Series [bug#55868] gnu: r-prereg: Add TeXLive dependencies. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Lars-Dominik Braun June 9, 2022, 12:26 p.m. UTC
* gnu/packages/cran.scm (r-prereg)[propagated-inputs]: Add
texlive-amsfonts, texlive-amsmath, texlive-booktabs,
texlive-etoolbox, texlive-generic-iftex, texlive-latex-fancyhdr,
texlive-latex-fancyvrb, texlive-latex-geometry, texlive-latex-graphics,
texlive-latex-threeparttable, texlive-latex-titlesec,
texlive-latex-upquote, texlive-listings, texlive-lm, texlive-polyglossia,
texlive-titling, texlive-tools, texlive-ulem.
---
 gnu/packages/cran.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)

Comments

Ricardo Wurmus June 9, 2022, 3:42 p.m. UTC | #1
Lars-Dominik Braun <lars@6xq.net> writes:

> +            (texlive-updmap.cfg (list texlive-amsfonts texlive-lm))))

What’s up with this one?  texlive-updmap.cfg isn’t supposed to be
propagated.  Why is it used with only these two texlive-* packages?

Should texlive-amsfonts and texlive-lm be moved one level up to
propagated-inputs instead, and texlive-updmap.cfg be removed?
Lars-Dominik Braun June 10, 2022, 7:09 a.m. UTC | #2
Hi Ricardo,

> > +            (texlive-updmap.cfg (list texlive-amsfonts texlive-lm))))
> 
> What’s up with this one?  texlive-updmap.cfg isn’t supposed to be
> propagated.  Why is it used with only these two texlive-* packages?
my understanding was that texlive-updmap.cfg is only useful for font
packages. Why is it not supposed to be propagated? I looked at
python-nbconvert as a reference, which does the same thing.

Cheers,
Lars
Ricardo Wurmus June 10, 2022, 3:57 p.m. UTC | #3
Lars-Dominik Braun <lars@6xq.net> writes:

> Hi Ricardo,
>
>> > +            (texlive-updmap.cfg (list texlive-amsfonts texlive-lm))))
>> 
>> What’s up with this one?  texlive-updmap.cfg isn’t supposed to be
>> propagated.  Why is it used with only these two texlive-* packages?
> my understanding was that texlive-updmap.cfg is only useful for font
> packages. Why is it not supposed to be propagated? I looked at
> python-nbconvert as a reference, which does the same thing.

My mistake.  I still remember texlive-union, which built a union
directory from its inputs — that union directory and its config file
could not be composed with other files or packages.  Propagating it
would have been pointless.

This texlive-union eventually gave way to texlive-updmap.cfg, which only
creates font map files, while propagating its inputs.  The font map
files should be usable as is, and since the inputs are propagated the
texlive-base profile hook can generate them anew (together with other
installed texlive-* packages) when needed.

So I guess this is fine after all.  Sorry for the noise!

I have applied your patch.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0299e0041e..c1f0dc08b7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -104,6 +104,7 @@  (define-module (gnu packages cran)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages statistics)
   #:use-module (gnu packages tcl)
+  #:use-module (gnu packages tex)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages uglifyjs)
@@ -30466,7 +30467,26 @@  (define-public r-prereg
     (properties `((upstream-name . "prereg")))
     (build-system r-build-system)
     (propagated-inputs
-      (list r-rmarkdown))
+      (list r-rmarkdown
+            ;; The package provides a custom LaTex template in
+            ;; inst/rmd/prereg_form.tex, which depends on these packages:
+            texlive-amsmath
+            texlive-booktabs
+            texlive-etoolbox
+            texlive-generic-iftex
+            texlive-latex-fancyhdr
+            texlive-latex-fancyvrb
+            texlive-latex-geometry
+            texlive-latex-graphics
+            texlive-latex-threeparttable
+            texlive-latex-titlesec
+            texlive-latex-upquote
+            texlive-listings
+            texlive-polyglossia
+            texlive-titling
+            texlive-tools
+            texlive-ulem
+            (texlive-updmap.cfg (list texlive-amsfonts texlive-lm))))
     (home-page "https://github.com/crsh/prereg")
     (synopsis
       "R Markdown Templates to preregister Scientific Studies")