diff mbox

[bug#55104,000/232] Update IPython to latest, fix texlive-polyglossia, add more

Message ID YmZvtT1jTcwTUFw7@noor.fritz.box
State Accepted
Headers show

Commit Message

Lars-Dominik Braun April 25, 2022, 9:53 a.m. UTC
Hi Maxim,

> This is the result of a quest to update IPython (to fix a reported CVE) and
> wanting to fix its Texinfo/PDF doc generation.  The later ended up being a
> rather deep rabbit hole, hence the following slurry of commits.  The end
> result is that we now have an up-to-date IPython and better support to build
> Sphinx-based documentation, a working texlive-polyglossia package (at least
> for XeLaTeX) and many new font tools that should allow us to build more fonts
> from source.
thank you very much for that update! I noticed python-qtconsole was
broken by the upgrade, see attached patches for fixes. There are alot
more failures on the CI, but it’s hard to tell whether they were caused
by this update or not.

Cheers,
Lars
From 9c905febfa1753e3468450e27150a187c30831d9 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <lars@6xq.net>
Date: Mon, 25 Apr 2022 11:36:20 +0200
Subject: [PATCH 1/2] gnu: python-qtpy: Update to 2.0.1.

* gnu/packages/qt.scm (python-qtpy): Update to 2.0.1.
[propagated-inputs]: Remove python-pyside-2, add python-packaging.
---
 gnu/packages/qt.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Maxim Cournoyer April 25, 2022, 1:15 p.m. UTC | #1
Hi Lars,

Lars-Dominik Braun <lars@6xq.net> writes:

> Hi Maxim,
>
>> This is the result of a quest to update IPython (to fix a reported CVE) and
>> wanting to fix its Texinfo/PDF doc generation.  The later ended up being a
>> rather deep rabbit hole, hence the following slurry of commits.  The end
>> result is that we now have an up-to-date IPython and better support to build
>> Sphinx-based documentation, a working texlive-polyglossia package (at least
>> for XeLaTeX) and many new font tools that should allow us to build more fonts
>> from source.
> thank you very much for that update! I noticed python-qtconsole was
> broken by the upgrade, see attached patches for fixes. There are alot
> more failures on the CI, but it’s hard to tell whether they were caused
> by this update or not.

One quick visual way to screen for big new groups of failed packages is
to compare the dashboards, e.g.:

https://ci.guix.gnu.org/eval/262363/dashboard vs https://ci.guix.gnu.org/eval/262877/dashboard

(this is for x86_64-linux).  You can see in this case they look pretty
identical to the eye.

It seems to be that most failures were already there on master (some
caused by the recent PyYAML update).  I've fixed some on my branch,
which may explain why the total succeeded builds is higher than master
(76% vs 67%, as seen in the "Jobs" column at https://ci.guix.gnu.org/).

I've applied these two patches and pushed to the branch; thank you!

Maxim
Lars-Dominik Braun April 26, 2022, 7:36 a.m. UTC | #2
Hi Maxim,

> One quick visual way to screen for big new groups of failed packages is
> to compare the dashboards, e.g.:
I’m not sure “eyeballing” these kind of changes is a good idea. On
the other hand I don’t have a better tool available right now either,
so yeah… :(

python-sanic (which we use) is also failing to build. Maybe we have to
upgrade that as well. I will try to fix it and send patches.

Cheers,
Lars
Simon Tournier April 26, 2022, 11:21 a.m. UTC | #3
Hi Maxim,

Thanks for this big update. :-)

On Mon, 25 Apr 2022 at 15:16, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

> It seems to be that most failures were already there on master (some
> caused by the recent PyYAML update).  I've fixed some on my branch,
> which may explain why the total succeeded builds is higher than master
> (76% vs 67%, as seen in the "Jobs" column at https://ci.guix.gnu.org/).

About PyYAML, please give a look at:

    https://issues.guix.gnu.org/54934


Cheers,
simon
Maxim Cournoyer April 27, 2022, 3:09 a.m. UTC | #4
Hi Lars-Dominik,

Lars-Dominik Braun <lars@6xq.net> writes:

> Hi Maxim,
>
>> One quick visual way to screen for big new groups of failed packages is
>> to compare the dashboards, e.g.:
> I’m not sure “eyeballing” these kind of changes is a good idea. On
> the other hand I don’t have a better tool available right now either,
> so yeah… :(

I did also browse one by one the failures, but only carefully for
x86_64, and summarily for other arches.  This allowed me to catch some
failing tests in numpy for i686-linux, for example.

> python-sanic (which we use) is also failing to build. Maybe we have to
> upgrade that as well. I will try to fix it and send patches.

OK, thanks!

Maxim
diff mbox

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0163d02bc0..bf2a3e88c2 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2269,17 +2269,16 @@  (define-public python-pyqt-builder
 (define-public python-qtpy
   (package
     (name "python-qtpy")
-    (version "1.9.0")
+    (version "2.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "QtPy" version))
        (sha256
           (base32
-           "13cw8l7zrhbdi03k1wl1pg9xdl4ahdfa7yz8gd0f23sxnm22rdrd"))))
+           "13zbhnl2rm30xafwrzfwdb4mjp7gk4s9h2xagbf83pnjzczhgzdd"))))
     (build-system python-build-system)
-    (propagated-inputs
-     `(("python-pyside2" ,python-pyside-2)))
+    (propagated-inputs (list python-packaging))
     (arguments
      `(;; Not all supported bindings are packaged. Especially PyQt4.
        #:tests? #f))