diff mbox series

[bug#49412,v2] gnu: libdrm: Update to 2.4.107.

Message ID YkoFaylFgRSVEzABW06lFTt0JxyggZcWtn0eailc8@cp4-web-034.plabs.ch
State Accepted
Headers show
Series [bug#49412,v2] gnu: libdrm: Update to 2.4.107. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Kaelyn Takata July 13, 2021, 4:57 p.m. UTC
* gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
libpciaccess to a propagated input as the pkg-config for libdrm_intel now
includes it in the libs.
* gnu/packages/xdisorg.scm (libdrm): Add conditional testing support to the
replacement for the standard check phase.
---
 gnu/packages/xdisorg.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Thiago Jung Bauermann July 26, 2021, 2:19 p.m. UTC | #1
Hello,

Em terça-feira, 13 de julho de 2021, às 13:57:48 -03, Kaelyn Takata via 
Guix-patches via escreveu:
> * gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
> libpciaccess to a propagated input as the pkg-config for libdrm_intel now
> includes it in the libs.
> * gnu/packages/xdisorg.scm (libdrm): Add conditional testing support to
> the replacement for the standard check phase.
> ---
>  gnu/packages/xdisorg.scm | 11 ++++++-----
>  1 file changed, 6 insertions(+), 5 deletions(-)

Thank you for this patch. FWIW, I applied it and built libdrm successfully 
on x86_64-linux. I also verified that the SHA256 sum matches the one from 
the official release announcement¹, and that:

$ ./pre-inst-env guix build --without-tests=libdrm plymouth

skips the libdrm tests.

I wasn’t able to find the OpenPGP key that signed the release tarball, so I 
couldn’t check its signature.
Ludovic Courtès July 31, 2021, 10:03 a.m. UTC | #2
Hi,

Kaelyn Takata <kaelyn.alexi@protonmail.com> skribis:

> * gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
> libpciaccess to a propagated input as the pkg-config for libdrm_intel now
> includes it in the libs.
> * gnu/packages/xdisorg.scm (libdrm): Add conditional testing support to the
> replacement for the standard check phase.

I tweaked the commit log and applied it.

Thank you, and thanks Maxime and Thiego for reviewing!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d0da2d28d1..dd30dbf844 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -638,7 +638,7 @@  rasterisation.")
 (define-public libdrm
   (package
     (name "libdrm")
-    (version "2.4.104")
+    (version "2.4.107")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -646,7 +646,7 @@  rasterisation.")
                     version ".tar.xz"))
               (sha256
                (base32
-                "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
+                "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
@@ -661,9 +661,10 @@  rasterisation.")
 
        #:phases (modify-phases %standard-phases
                   (replace 'check
-                    (lambda _
-                      (invoke "meson" "test" "--timeout-multiplier" "5"))))))
-    (inputs
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "meson" "test" "--timeout-multiplier" "5")))))))
+    (propagated-inputs
      `(("libpciaccess" ,libpciaccess)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))