diff mbox series

[bug#54445] gnu: Add cl-purgatory.

Message ID YjR5Mxe/XShE3DSh@kurosawa.casa.net
State Accepted
Headers show
Series [bug#54445] gnu: Add cl-purgatory. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

cage March 18, 2022, 12:21 p.m. UTC
---
 gnu/packages/lisp-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

--
2.34.0

Comments

Guillaume Le Vaillant March 18, 2022, 1:22 p.m. UTC | #1
Patch pushed as cab5f92836ec52b0c524aa2541f3cdcd6c5ceb6e with a few
modifications (updated copyright line, fixed synopsis, used new style
for inputs).
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0c99518e82..4d0da2993a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20823,3 +20823,37 @@  (define-public cl-websocket-driver

 (define-public ecl-websocket-driver
   (sbcl-package->ecl-package sbcl-websocket-driver))
+
+(define-public sbcl-purgatory
+  (let ((commit "ade0d60a14a1067b9cc8cf06d1f1a1ca8cecdb03")
+        (revision "1"))
+    (package
+      (name "sbcl-purgatory")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://notabug.org/cage/purgatory")
+               (commit commit)))
+         (file-name (git-file-name "purgatory" version))
+         (sha256
+          (base32 "1mwlalymmfbx1jx5wzqcnpg5h8d0ylllm1p3f4lwaawfv05lk82s"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+         ("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)
+         ("bordeaux-threads" ,sbcl-bordeaux-threads)
+         ("usocket" ,sbcl-usocket)
+         ("babel" ,sbcl-babel)))
+      (synopsis "Common Lisp library to make histograms")
+      (description "This is a Common Lisp library that implement
+the 9p network filesystem protocol.")
+      (home-page "https://notabug.org/cage/purgatory/")
+      (license license:llgpl))))
+
+(define-public ecl-purgatory
+  (sbcl-package->ecl-package sbcl-purgatory))
+
+(define-public cl-purgatory
+  (sbcl-package->cl-source-package sbcl-purgatory))