diff mbox series

[bug#49929] gnu: Add gmid.

Message ID YhpNFaejB2rBEN9/@kurosawa.casa.net
State Accepted
Headers show
Series [bug#49929] gnu: Add gmid. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

cage Feb. 26, 2022, 3:53 p.m. UTC
On Wed, Feb 23, 2022 at 11:33:59PM -0500, Maxim Cournoyer wrote:

Hi!

Thanks for your feedback!

[...]

> The rest looks good to me, well done!
> Could you send an update with changes along these lines?

Here is  my best  attempt to  fix the  definition form  following your
advice; i  have enabled  the 'check' phase  and removed  the backtick
notation.  I  was not  able to  update the  call to  'invoke', because
-honestly- i was  not able to wrap  my head around g-expr.  I hope the
results are acceptable by the way! :)

Bye and thanks again!
C.

---
 gnu/packages/networking.scm | 38 +++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

--
2.34.0

Comments

Maxim Cournoyer Feb. 27, 2022, 4:50 a.m. UTC | #1
Hello!

cage <cage-dev@twistfold.it> writes:

> On Wed, Feb 23, 2022 at 11:33:59PM -0500, Maxim Cournoyer wrote:
>
> Hi!
>
> Thanks for your feedback!
>
> [...]
>
>> The rest looks good to me, well done!
>> Could you send an update with changes along these lines?
>
> Here is  my best  attempt to  fix the  definition form  following your
> advice; i  have enabled  the 'check' phase  and removed  the backtick
> notation.  I  was not  able to  update the  call to  'invoke', because
> -honestly- i was  not able to wrap  my head around g-expr.  I hope the
> results are acceptable by the way! :)

Thank, that's much nicer with the test suite!  I moved the package to
(gnu packages web), updated it to 1.8.1 (per 'guix lint'
recommendation), ordered the inputs, simplified the phase a bit and
enumerated some of the supported features in the description.

I also fixed the license, which is ISC rather than X11 (see
https://directory.fsf.org/wiki/License:ISC).

Pushed as 7eb68770efb33c1444f0ba1654334cfe19b3f5c6.

Closing; thank you!

Maxim

> Bye and thanks again!
> C.
>
> ---
>  gnu/packages/networking.scm | 38 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index 11f1cad007..49776fd666 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -48,6 +48,7 @@
>  ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
>  ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
>  ;;; Copyright © 2022 Simon South <simon@simonsouth.net>
> +;;; Copyright © 2022 cage <cage-dev@twistfold.it>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -4196,3 +4197,40 @@ (define-public putty
>  implementations.")
>      (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
>      (license license:expat)))
> +
> +(define-public gmid
> +  (package
> +    (name "gmid")
> +    (version "1.7.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/omar-polo/gmid/releases/download/"
> +                           version "/gmid-" version ".tar.gz"))
> +       (sha256
> +        (base32 "0ag5zcwnr5vmy13bc9c36hnv9pflks68b0k6w0ng97inrm37klis"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     (list #:test-target "regress"
> +           #:phases
> +           #~(modify-phases %standard-phases
> +               (replace 'configure
> +                 ;; The configure script is hand-written, not from GNU autotools.
> +                 (lambda* (#:key configure-flags inputs outputs #:allow-other-keys)
> +                   (let ((prefix (string-append "PREFIX=" (assoc-ref outputs "out"))))
> +                     (setenv "CC" #$(cc-for-target))
> +                     (apply invoke "./configure" (list prefix))))))))
> +    (native-inputs
> +     (list pkg-config
> +           bison
> +           flex
> +           coreutils
> +           which
> +           procps))
> +    (inputs
> +     (list libevent
> +           libressl))
> +    (home-page "https://git.omarpolo.com/gmid/about/")
> +    (synopsis "Simple and secure Gemini server")
> +    (description "Gmid is a fast Gemini server written with security in mind.")
> +    (license license:x11)))
> --
> 2.34.0
cage Feb. 27, 2022, 12:06 p.m. UTC | #2
On Sat, Feb 26, 2022 at 11:50:18PM -0500, Maxim Cournoyer wrote:
> Hello!

Hi!!

[...]

> > Here is  my best  attempt to  fix the  definition form  following your
> > advice;

[...]

> Thank, that's much nicer with the test suite!

The upstream developer has spent a lot of time writing a proper test
suite, was a pity if was left unused. :)

[...]

> Closing; thank you!

Thanks to you for your suggestions and improving the patch!

Also i was able to fix the  package's test phase only with the help of
people from the IRC channel, thanks to they all!

I  am  going  to  track  the development  upstream  and  upgrade  this
definition form in the future.


Bye!
C.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 11f1cad007..49776fd666 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -48,6 +48,7 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Simon South <simon@simonsouth.net>
+;;; Copyright © 2022 cage <cage-dev@twistfold.it>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4196,3 +4197,40 @@  (define-public putty
 implementations.")
     (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
     (license license:expat)))
+
+(define-public gmid
+  (package
+    (name "gmid")
+    (version "1.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/omar-polo/gmid/releases/download/"
+                           version "/gmid-" version ".tar.gz"))
+       (sha256
+        (base32 "0ag5zcwnr5vmy13bc9c36hnv9pflks68b0k6w0ng97inrm37klis"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:test-target "regress"
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'configure
+                 ;; The configure script is hand-written, not from GNU autotools.
+                 (lambda* (#:key configure-flags inputs outputs #:allow-other-keys)
+                   (let ((prefix (string-append "PREFIX=" (assoc-ref outputs "out"))))
+                     (setenv "CC" #$(cc-for-target))
+                     (apply invoke "./configure" (list prefix))))))))
+    (native-inputs
+     (list pkg-config
+           bison
+           flex
+           coreutils
+           which
+           procps))
+    (inputs
+     (list libevent
+           libressl))
+    (home-page "https://git.omarpolo.com/gmid/about/")
+    (synopsis "Simple and secure Gemini server")
+    (description "Gmid is a fast Gemini server written with security in mind.")
+    (license license:x11)))