diff mbox series

[bug#53552] gnu: python-uvloop: Skip failing test on PowerPC.

Message ID YfGJZ2HYAMcI88A6@noor.fritz.box
State New
Headers show
Series [bug#53552] gnu: python-uvloop: Skip failing test on PowerPC. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Lars-Dominik Braun Jan. 26, 2022, 5:48 p.m. UTC
* gnu/packages/python-web.scm (python-uvloop)[arguments]: Conditionally
skip test on target-powerpc?.
---
 gnu/packages/python-web.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)


Hi,

can someone using a PowerPC machine please verify this fixes the build
failure here: https://ci.guix.gnu.org/build/424653/details

Thanks,
Lars
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 406c6cb51b..1c90fde331 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4644,7 +4644,11 @@  (define-public python-uvloop
                               ;; It looks like pytest is preventing
                               ;; custom stdout/stderr redirection,
                               ;; even with -s.
-                              "and not test_process_streams_redirect "))))))))
+                              "and not test_process_streams_redirect "
+                              ;; Fails for unknown reasons.
+                              (if target-powerpc?
+                                  "and not test_write_buffer_full "
+                                  "")))))))))
     (native-inputs
      (list python-aiohttp
            python-cython