diff mbox series

bug#51500: [PATCH] gnu: Add kiwix-tools

Message ID Ya/gSDq0sVsmMHMl@jasmine.lan
State Accepted
Headers show
Series bug#51500: [PATCH] gnu: Add kiwix-tools | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Leo Famulari Dec. 7, 2021, 10:29 p.m. UTC
On Sat, Oct 30, 2021 at 07:36:31AM +0200, Denis 'GNUtoo' Carikli wrote:
> * gnu/packages/web.scm (kiwix-tools): New variable.

Thanks for the patch!

I pushed as 9e67f2ad418e9a5a7a83dc2349624572e9dbfc8b with minor changes,
shown below.

> +    (license license:gpl3)))

I also changed the license to 'gpl3+', because the source files include
the phrase "either version 3 of the License, or any later version", and
README.md confirms that the authors intend to allow licensing under
later GPL revisions.

And I added you to the list of authors of 'gnu/packages/web.scm'.

------
------
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 05cbf4d8cc..2f2ed4d8d2 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8133,10 +8133,8 @@  (define-public kiwix-tools
     (version "3.1.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "https://download.kiwix.org/release/kiwix-tools/kiwix-tools-"
-                    version
-                    ".tar.xz"))
+              (uri (string-append "https://download.kiwix.org/release/"
+                                  "kiwix-tools/kiwix-tools-" version ".tar.xz"))
               (sha256
                (base32
                 "1npf9ddhpkmx97gxmvmwmi8a69md8kh2szimd9rpg6ggd4big03a"))))
@@ -8155,7 +8153,7 @@  (define-public kiwix-tools
      `(("pkg-config" ,pkg-config)))
     (home-page "https://wiki.kiwix.org/wiki/Software")
     (synopsis "Kiwix command line tools")
-    (description "The Kiwix tools is a collection of Kiwix related command line
+    (description "The Kiwix tools are a collection of Kiwix-related command line
 tools:
 @itemize
 @item kiwix-manage: Manage XML based library of ZIM files
@@ -8163,7 +8161,7 @@  (define-public kiwix-tools
 @item kiwix-search: Fulltext search in ZIM files
 @item kiwix-serve: HTTP daemon serving ZIM files
 @end itemize\n")
-    (license license:gpl3)))
+    (license license:gpl3+)))
 
 (define-public uriparser
   (let ((commit "25dddb16cf044a7df27884e7ad3911baaaca3d7c")