diff mbox series

[bug#51990] gnu: Add emacs-bazel.

Message ID YZg94OdgZs/3Inzy@neutron
State Accepted
Headers show
Series [bug#51990] gnu: Add emacs-bazel. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brian Kubisiak Nov. 20, 2021, 12:14 a.m. UTC
* gnu/packages/emacs-xyz (emacs-bazel): New variable.

Signed-off-by: Brian Kubisiak <brian@kubisiak.com>
---
 gnu/packages/emacs-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Nicolas Goaziou Nov. 21, 2021, 8:30 p.m. UTC | #1
Hello,

Brian Kubisiak <brian@kubisiak.com> writes:

> * gnu/packages/emacs-xyz (emacs-bazel): New variable.

Thank you. Some comments follow.
>
> Signed-off-by: Brian Kubisiak <brian@kubisiak.com>

We don't sign our own commits. So the line above is not necessary.

> +(define-public emacs-bazel
> +  (package
> +    (name "emacs-bazel")
> +    (version "20211031.1941")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://melpa.org/packages/bazel-"
> +                           version ".el"))

We don't trust MELPA as a reliable source. Could you use git-fetch
instead, and get source files from upstream instead?

Also, the version is "O", according to "Version" keyword in "bazel.el"
file.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7f895b9321..15d57ad964 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12844,6 +12844,25 @@  (define-public emacs-gn-mode
 are common in Chromium-derived projects.")
     (license license:bsd-3)))
 
+(define-public emacs-bazel
+  (package
+    (name "emacs-bazel")
+    (version "20211031.1941")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://melpa.org/packages/bazel-"
+                           version ".el"))
+       (sha256
+        (base32 "185wqxcdk5c5d25vla3wgijwqs542dbqwnj47bnh5hvlna2il6ca"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/bazelbuild/emacs-bazel-mode")
+    (synopsis "Bazel support for Emacs")
+    (description
+     "This package provides support for the Bazel build system.  See
+@uref{https://bazel.build/} for background on Bazel.")
+    (license license:asl2.0)))
+
 (define-public emacs-gntp
   (package
     (name "emacs-gntp")