diff mbox series

[bug#50859,core-updates-frozen] gnu: tzdata: Update to 2021b.

Message ID YXhAfSF8mdPS4f5A@jasmine.lan
State Accepted
Headers show
Series [bug#50859,core-updates-frozen] gnu: tzdata: Update to 2021b. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Oct. 26, 2021, 5:53 p.m. UTC
Leo Famulari <leo@famulari.name> writes:
> Here is another update, in case you haven't started building yet.

And another update, to 2021e... attached.
From d9b32f6c97f05314bf8b213c69e1546819351056 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Sun, 26 Sep 2021 22:38:25 -0400
Subject: [PATCH] gnu: tzdata: Update to 2021e.

* gnu/packages/base.scm (tzdata, tzdata-for-tests): Update to 2021e.
---
 gnu/packages/base.scm | 32 +++++++-------------------------
 1 file changed, 7 insertions(+), 25 deletions(-)

Comments

Maxim Cournoyer Nov. 12, 2021, 5:50 a.m. UTC | #1
Hello Leo,

Leo Famulari <leo@famulari.name> writes:

> Leo Famulari <leo@famulari.name> writes:
>> Here is another update, in case you haven't started building yet.
>
> And another update, to 2021e... attached.

Applied with commit af8b03b4e26ec1e50559062d3115398eb6a63c2c.

Thanks,

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 174af43917..ab67a5d862 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1230,7 +1230,7 @@  command.")
     (name "tzdata")
     ;; This package should be kept in sync with python-pytz in (gnu packages
     ;; time).
-    (version "2021a")
+    (version "2021e")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -1238,7 +1238,7 @@  command.")
                    version ".tar.gz"))
              (sha256
               (base32
-               "022fn6gkmp7pamlgab04x0dm5hnyn2m2fcnyr3pvm36612xd5rrr"))))
+               "1cdjdcxl0s9xf0dg1z64kh7llm80byxqlzrkkjzcdlyh6yvl5v07"))))
     (build-system gnu-build-system)
     (arguments
      (list #:tests? #f
@@ -1306,7 +1306,7 @@  command.")
                           version ".tar.gz"))
                     (sha256
                      (base32
-                      "1l02b0jiwp3fl0xd6227i69d26rmx3yrnq0ssq9vvdmm4jhvyipb")))))
+                      "0x8pcfmjvxk29yfh8bklchv2f0vpl4yih0gc4wyx292l78wncijq")))))
     (home-page "https://www.iana.org/time-zones")
     (synopsis "Database of current and historical time zones")
     (description "The Time Zone Database (often called tz or zoneinfo)
@@ -1321,28 +1321,10 @@  and daylight-saving rules.")
 ;;; thousands of packages (for example, in a core-updates rebuild). This package
 ;;; will typically be obsolete and should never be referred to by a built
 ;;; package.
-(define-public tzdata-for-tests
-  (hidden-package
-   (package
-     (inherit tzdata)
-     (version "2021a")
-     (source (origin
-               (method url-fetch)
-               (uri (string-append
-                     "https://data.iana.org/time-zones/releases/tzdata"
-                     version ".tar.gz"))
-               (sha256
-                (base32
-                 "022fn6gkmp7pamlgab04x0dm5hnyn2m2fcnyr3pvm36612xd5rrr"))))
-     (inputs
-      (list (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://data.iana.org/time-zones/releases/tzcode"
-                    version ".tar.gz"))
-              (sha256
-               (base32
-                "1l02b0jiwp3fl0xd6227i69d26rmx3yrnq0ssq9vvdmm4jhvyipb"))))))))
+;;;
+;;; Please make this a hidden-package if it is different from the primary tzdata
+;;; package.
+(define-public tzdata-for-tests tzdata)
 
 (define-public libiconv
   (package