diff mbox

[bug#51413,00/45] Stackage update to 18.14

Message ID YXfvA0C+smxZt+9i@noor.fritz.box
State Accepted
Headers show

Commit Message

Lars-Dominik Braun Oct. 26, 2021, 12:05 p.m. UTC
Hi everyone,

this is another episode in the never-ending quest to keep Haskell packages
updated. This series only updates packages on Stackage by running

	guix refresh -u -t stackage 2>&1 | tee upgrades.log

and adjusting dependency changes by hand and then running
etc/committer.scm to create the commits themselves. It looks like
`guix refresh` swallows exceptions and there’s a bug somewhere in the
Stackage updater, so this process needs to be repeated until there are
no more updates.

There is a branch wip-stackage-18.14, which has been run through the CI
successfully: https://ci.guix.gnu.org/jobset/wip-stackage-18.14

Cheers,
Lars

Lars-Dominik Braun (45):
  import: stackage: Update to release 18.14.
  gnu: ghc-tasty-silver: Update to 3.2.3.
  gnu: ghc-cryptohash-md5: Update to 0.11.101.0.
  gnu: ghc-cryptohash-sha256: Update to 0.11.102.1.
  gnu: ghc-puremd5: Update to 2.1.4.
  gnu: ghc-hsopenssl: Update to 0.11.7.2.
  gnu: ghc-wai-extra: Update to 3.1.7.
  gnu: ghc-warp-tls: Update to 3.3.2.
  gnu: ghc-aeson-pretty: Update to 0.8.9.
  gnu: ghc-aeson-qq: Update to 0.8.4.
  gnu: ghc-aeson-compat: Update to 0.3.10.
  gnu: ghc-async: Update to 2.2.4.
  gnu: ghc-blaze-builder: Update to 0.4.2.2.
  gnu: ghc-bytestring-lexing: Update to 0.5.0.7.
  gnu: ghc-cassava-megaparsec: Update to 2.0.4.
  gnu: ghc-esqueleto: Update to 3.5.3.0.
  gnu: ghc-hpack: Update to 0.34.5.
  gnu: ghc-hslua: Update to 1.3.0.2.
  gnu: ghc-ipynb: Update to 0.1.0.2.
  gnu: ghc-juicypixels: Update to 3.3.6.
  gnu: ghc-lzma-conduit: Update to 1.2.2.
  gnu: ghc-mono-traversable: Update to 1.0.15.3.
  gnu: ghc-operational: Update to 0.2.4.0.
  gnu: ghc-emojis: Update to 0.1.2.
  gnu: ghc-doclayout: Update to 0.3.1.1.
  gnu: ghc-pandoc-types: Update to 1.22.1.
  gnu: ghc-persistent: Update to 2.13.2.1.
  gnu: ghc-prettyprinter: Update to 1.7.1.
  gnu: ghc-prettyprinter-ansi-terminal: Update to 1.1.3.
  gnu: ghc-regex-pcre-builtin: Update to 0.95.2.3.8.44.
  gnu: ghc-semigroupoids: Update to 5.3.6.
  gnu: ghc-stm-chans: Update to 3.0.0.6.
  gnu: ghc-texmath: Update to 0.12.3.2.
  gnu: ghc-tldr: Update to 0.9.2.
  gnu: ghc-tree-diff: Update to 0.2.1.
  gnu: ghc-typed-process: Update to 0.2.6.3.
  gnu: ghc-vector: Update to 0.12.3.1.
  gnu: ghc-x11: Update to 1.10.2.
  gnu: ghc-yaml: Update to 0.11.7.0.
  gnu: ghc-zstd: Update to 0.1.3.0.
  gnu: ghc-commonmark: Update to 0.2.1.1.
  gnu: ghc-commonmark-extensions: Update to 0.2.2.
  gnu: ghc-mysql: Update to 0.2.1.
  gnu: ghc-mysql-simple: Update to 0.4.7.
  gnu: ghc-persistent-postgresql: Update to 2.13.2.1.

 gnu/packages/haskell-check.scm  |  12 +-
 gnu/packages/haskell-crypto.scm |  24 ++--
 gnu/packages/haskell-web.scm    |  26 ++--
 gnu/packages/haskell-xyz.scm    | 228 ++++++++++++++++----------------
 guix/import/stackage.scm        |   2 +-
 5 files changed, 144 insertions(+), 148 deletions(-)

Comments

Lars-Dominik Braun Oct. 29, 2021, 6:02 p.m. UTC | #1
Hi Ludo,

> Adjusting them by hand following recommendations printed by ‘guix
> refresh’?
yes, that is (mostly) correct. There are some errors like suggestions
to remove native libraries or hspec that should be ignored though.

> > and then running etc/committer.scm to create the commits
> > themselves. It looks like `guix refresh` swallows exceptions and
> > there’s a bug somewhere in the Stackage updater, so this process needs
> > to be repeated until there are no more updates.
> Uh, would be nice to investigate.
Will do when I have the time.

> If CI doesn’t report a greater number of build failures compared to the
> base commit, I’d say you can go ahead and merge.
The numbers are not comparable, because master builds more
architectures. But the failures I see are either not new or not related
to Haskell upgrades (on x86_64). I’ll rebase and merge in the coming
days. Thanks!

Cheers,
Lars
Lars-Dominik Braun Nov. 2, 2021, 6:01 p.m. UTC | #2
Hi,

I merged this change as commit 5e8b18dbb1632ad1b5f297308960989088985db0 and earlier.

Cheers,
Lars
diff mbox

Patch

From e7487b6b9a6f101f987be7ac5daef4b133e46713 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <lars@6xq.net>
Date: Mon, 25 Oct 2021 14:28:43 +0200
Subject: [PATCH 45/45] gnu: ghc-persistent-postgresql: Update to 2.13.2.1.

* gnu/packages/haskell-xyz.scm (ghc-persistent-postgresql): Update to 2.13.2.1.
---
 gnu/packages/haskell-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index ddad796c9d..6fb6933be4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16458,7 +16458,7 @@  (define-public ghc-postgresql-simple
 (define-public ghc-persistent-postgresql
   (package
     (name "ghc-persistent-postgresql")
-    (version "2.13.1.0")
+    (version "2.13.2.1")
     (source
      (origin
        (method url-fetch)
@@ -16467,7 +16467,7 @@  (define-public ghc-persistent-postgresql
              version
              ".tar.gz"))
        (sha256
-        (base32 "05bj3b7kdwaba3szrrsmafxr6vcnvdhq20jk5xx348jnf2flkw0i"))))
+        (base32 "07pnr8m0nk43jaz6l293lzx4ivyqgnw94fjypazzm008b4irh7ir"))))
     (build-system haskell-build-system)
     (arguments `(#:tests? #f)) ; TODO: Cannot import MaybeFieldDefsTest.
     (inputs
-- 
2.32.0